New GeForce RTX 2060 graphics card not working with Manjaro

Hi all.

I have just installed a GeForce RTX 2060 graphics card for my son - he runs Windows 10 on a separate SSD for gaming.

For some reason I cannot we cannot get Manjaro running on the new graphics card. I checked my hardware configuration via the Control Panel & it says I have the mhwd-nvidia-440xx drivers installed.

I am stumped, so any assistance would be greatly appreciated.

Thanks & more power to the Manjaro community.



I’ll recommend to switch to video-nvidia-455xx in Manjaro.
sudo mhwd -r pci video-nvidia-440xx
and then
sudo mhwd -i pci video-nvidia-455xx

If CUDA is installed, remove it first. I recommend also the 5.9 kernel …

Hi bogdancovacui.

Thanks for your assistance. I ran the commands & received the following:

Blockquote> > Removing video-nvidia-440xx…
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-440xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58-nvidia-440xx breaks dependency ‘linux58-nvidia-440xx’ required by linux-latest-nvidia-440xx
Error: pacman failed!
Error: script failed!
[ruziel@RZL ~]$ sudo mhwd -i pci video-nvidia-455xx
Error: config ‘video-nvidia-455xx’ conflicts with config(s): video-nvidia-440xx
[ruziel@RZL ~]$


Thanks in advance.


sudo pacman -R linux58-nvidia-440xx nvidia-440xx-utils
and then

Thanks. I tried the new command you suggested first & get the following:

Blockquote [ruziel@RZL ~]$ sudo pacman -R linux58-nvidia-440xx nvidia-440xx-utils
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils’ required by lib32-nvidia-440xx-utils
:: removing linux58-nvidia-440xx breaks dependency ‘linux58-nvidia-440xx’ required by linux-latest-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils=440.100’ required by linux54-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils=440.100’ required by linux57-nvidia-440xx


Thanks for your assistance.


You can also drop the linux57
sudo mhwd-kernel -r linux57

sudo pacman -R linux-latest linux-latest-nvidia-440xx linux58-nvidia-440xx linux54-nvidia-440xx nvidia-440xx-utils lib32-nvidia-440xx-utils

Thanks. I followed the initial suggestions & booted up with 5.9.

On boot-up, I receive the notification, FAILED: Failed to start light display manager.

Thanks again.


But it loads fine with other kernel ?

Hi. Unfortunately not. On the 5.9 kernel I get the “Failed to start light display manager” and on 5.4 kernel, I boot up & just get a blinking _ in the top left hand corner.

As the moment I use my own monitor, plugged into the internal graphics port. Every time he wants to game I have to go into BIOS & reset the graphics from IDG to PEG. I hope for us to use just one monitor.

Much appreciated!


Then mhwd created a bogus /etc/X11/mhwd.d/nvidia.conf that will not help in your case.

Another way is to use the hybrid drivers.

Thanks for your input. I’m not sure I want to get into hybrid drivers, given my very basic knowledge level.

Maybe getting the right lead to connect my internal graphics with his gaming monitor will be the easiest.

I appreciate your assistance.


Please post the
inxi -Fazy
so someone into hybrid GPUs might give you a hint based on that infomration.

Thanks. Here goes:

Blockquote [ruziel@RZL ~]$ inxi -Fazy
Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
root=UUID=7a3a3c0d-07c7-4cab-8c85-ea0b3a1e1be2 rw quiet udev.log_priority=3
Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Type: Desktop Mobo: Micro-Star model: Z370-A PRO (MS-7B48) v: 1.0
serial: UEFI: American Megatrends v: 2.20 date: 10/27/2017
Info: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Kaby Lake
family: 6 model-id: 9E (158) stepping: A (10) microcode: DE
L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 76831
Speed: 4436 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4438 2: 4400
3: 4420 4: 4437 5: 4449 6: 4456 7: 4417 8: 4405 9: 4356 10: 4371 11: 4354
12: 4590
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:3e92
Device-2: NVIDIA TU104 [GeForce RTX 2060] vendor: Gigabyte driver: N/A
alternate: nouveau bus ID: 01:00.0 chip ID: 10de:1e89
Display: x11 server: 1.20.9 driver: intel alternate: nvidia
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.2
direct render: Yes
Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0
Device-2: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:10f8
Device-3: Plantronics DA40 Adapter type: USB
driver: plantronics,snd-usb-audio,usbhid bus ID: 1-11:6 chip ID: 047f:da40
Sound Server: ALSA v: k5.9.8-2-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac:
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Local Storage: total: 1.36 TiB used: 62.42 GiB (4.5%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB
block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
serial: rev: 3B7QCXE7 scheme: GPT
ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 3B6Q scheme: GPT
ID-3: /dev/sdb vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 7200 rpm serial: rev: CC43 scheme: MBR
ID-1: / raw size: 198.12 GiB size: 194.01 GiB (97.93%)
used: 62.39 GiB (32.2%) fs: ext4 dev: /dev/nvme0n1p2
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.47 GiB used: 33.2 MiB (0.1%)
priority: -2 dev: /dev/nvme0n1p3
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Processes: 378 Uptime: 1h 15m Memory: 31.29 GiB used: 13.31 GiB (42.5%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1261 lib: 367
Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08

Thanks again. R.

There is new BIOS for it

If you want to keep using it that way you can safely enable both from BIOS settings and run:
sudo mhwd -r pci video-nvidia-455xx
to remove that driver and install the hybrid one
sudo mhwd -i pci video-hybrid-intel-nvidia-455xx-prime

That way at least you will have the proper default config to use one GPU or the other when a display is connected, and no need to keep changing the BIOS. Personally i avoid all this fuss with the iGPU, and i would completely disable it, but …
Anyway, for the dGPU when installing the non hybrid driver is good to have a connected display to it.

Thanks. Regarding your comments:

  1. How do I “enable both from BIOS”? Maybe I am misunderstanding you.

Maybe you mean I must just run the two commands you suggested & that this will mean I don’t have to keep going into the BIOS to change from IDG to PEG etc.

I just want to avoid making a mistake & creating another problem :slight_smile:

Much appreciated!


I don’t know the BIOS of that model. Some can enable both GPUs or just one … some enable those automatically when set to IDG and there is a dGPU (PCIe graphics card) with a monitor connected, but in that case you can’t have a /etc/X11/mhwd.d/nvidia.conf because that will get priority when booting in linux, but will fail, as already happen to you, because you had no Display connected to it as you connected it to the iGPU. That is how video-hybrid-intel-nvidia-455xx-prime comes into play if you want to go that road.

Another way is to keep video-nvidia-455xx but remove the /etc/X11/mhwd.d/nvidia.conf if BIOS is set to IDG, so both GPUs work, otherwise the iGPU will fail because the nvidia will hijack xorg, but because what i explained above, the lack of a Display connected when you installed the driver, as was connected to iGPU, the config is not proper, hence will also fail even if you now connect the Display to the dGPU.

Thanks a lot. I will give it some thought & go from there. Wishing you a great weekend. Much appreciated. Ruziel.

One thought - would it help if I completely reinstalled Manjaro? Maybe it would pick up the new graphics card & configure automatically. Thanks, R.