New driver NTFS3 (with Kernel 5.15.2) is not working properly

With the recent update of Manjaro KDE Plasma, I chose to use kernel 5.15.2-2 and I tried to replace my current driver ntfs-3g to ntfs3 in my file /etc/fstab like this:


/dev/sdc1       /home/userx/WDisk02  ntfs-3g defaults,noatime        0 0
/dev/sda1       /home/userx/WDisk03  ntfs-3g defaults,noatime        0 0


/dev/sdc1       /home/userx/WDisk02  ntfs3 defaults,noatime        0 0
/dev/sda1       /home/userx/WDisk03  ntfs3 defaults,noatime        0 0

After rebooting my OS, /dev/sdc1 is “apparently” working fine (read/write, root), however /dev/sda1 is set in readonly mode only. I’ve booted to Windows to check those drives, then I returned to Linux and the problem persists.

Any ideas about this problem? Is it recommended to use NTFS3 driver? Thanks.

first you shouldn’t be using /dev/sdXX in your fstab file, this is not consistent across reboots, use the UUID, this never changes.

On my side I use uid and gid as mount options to give ownership to my user on mount. On a single user system it is alright to do so I guess.

I’ve changed my fstab file to this:

UUID=E264B2DA64B2B0A1   /home/userx/WDisk02  ntfs3 defaults,noatime,uid=1000,gid=1000      0 0
UUID=BA12CDCA12CD8C37   /home/userx/WDisk03  ntfs3 defaults,noatime,uid=1000,gid=1000      0 0

And same problem with the second drive. The strange thing is that with ntfs-3g there’s no problem.

try sudo chown -R user:usergroup /mount/path or sudo chmod -R -v 777 /mount/path
I had to do this after changing ntfs-3g to nfts3 to be able to write on the disk
I use my external drive as just download folder so if you have there more complex stuff not sure if that’s okay to do

My fstab has these arguments ntfs3 defaults,noatime,uid=user,gid=usergroup,nofail,iocharset=utf8 0 0 for the drive

1 Like