New Canon printer works on Ubuntu VB guest but not on manjaro host

It’s a Canon Pixma TS6350a. Only had it a week or so, having had to “click & collect” in a hurry and didn’t anticipate problems installing. It’s connected to the home network as well as by usb to the desktop. Just couldn’t get it to work on my Manjaro-Gnome desktop, even after downloading .deb drivers from Canon and converting with debtap - after which the install seemed to go smoothly and various iterations of the printer appeared in cups and the printer manager (see screenshot) but none of them worked: no response from the printer at all. After a lot of googling and troubleshooting in desperation I booted up Ubuntu in VirtualBox, running on the same Manjaro desktop, and it found it straight away and I printed a successful test page. Then after doing some printing from Ubuntu I tried back on Manjaro and suddenly it worked, though I’m not aware of having done anything different. The next day, though, the printer itself offered a firmware update, which I accepted and it was successful, but it did for the Manjaro installation and this time it hasn’t come back. I’ve been printing through VB Ubuntu ever since. That seems to be using the usb connection, as I lose functionality if I forget to enable it in the VB devices usb manager.
I’m flummoxed. I’ve tried several times to remove it from Printers and reinstall, but to no avail. I’m sure it’s a simple fix if you know what you’re doing, but when it comes to drivers etc I don’t, and if they don’t get picked up as they should I’m at a loss. Hence this appeal for assistance.

NB. In Ubuntu it appears in Printers as “Canon_TS6300_series_USB Model: Canon TS6300 series”
NB. The Epson is the one the Canon is replacing, that packed up after less than a year and has had to go back to the shop.

This is the driver that you need:

Install via pamac GUI or in terminal:

pamac build canon-pixma-g6000-complete  

See also:

Sorted! Thank you so much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.