NetworkManager successfully connects to router but not internet

I’m having trouble connecting to the internet. From what I can tell, I’m connecting to the router fine but I can’t connect to any website using firefox or web browser. Other devices on the network connect just fine, my windows 10 partition connects just fine, and the live usb connects fine (that’s what I’m using to post right now). I’ve also tried using a completely new network with the same issues. I’ve tried restarting NetworkManager using $ systemctl restart NetworkManager , removing the network and readding it, various different configuration options in the gui, and dissabling MAC address randomization (all suggestions I found in other posts but none have worked for me).

Here are relevant outputs:
inxi --full --verbosity=7 --filter --no-host

  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop Mobo: N/A model: N/A serial: <superuser required>
    UEFI: American Megatrends v: GL118 date: 07/30/2020
  ID-1: BAT0 charge: 34.2 Wh (100.0%) condition: 34.2/N/A Wh volts: 7.6
    min: 7.6 model: N/A type: Unknown serial: <filter> status: Full
  RAM: total: 7.58 GiB used: 1 GiB (13.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: quad core model: Intel Celeron J4115 bits: 64 type: MCP
    smt: <unsupported> arch: Goldmont Plus rev: 1 cache: L1: 224 KiB L2: 4 MiB
  Speed (MHz): avg: 1316 high: 1704 min/max: 800/2500 cores: 1: 1704
    2: 1519 3: 1083 4: 958 bogomips: 14288
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
    arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt cmov constant_tsc
    cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms
    est flexpriority fpu fsgsbase fxsr ht ibpb ibrs ibrs_enhanced ida
    intel_pt lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pdpe1gb pebs pge pln pni
    popcnt pse pse36 pti pts rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg
    sep sha_ni smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
    tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip
    vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300
  Device-2: Y Media USB Camera type: USB driver: uvcvideo bus-ID: 1-6:3
    chip-ID: 0bdc:0320 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting alternate: fbdev,vesa s-res: 1920x1080 s-dpi: 96
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    vendor: Realtek driver: snd_hda_intel v: kernel bus-ID: 00:0e.0
    chip-ID: 8086:3198 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce v: N/A port: e000 bus-ID: 01:00.0 chip-ID: 10ec:c821
    class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:2 chip-ID: 0bda:c821 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 119.24 GiB used: 40.62 GiB (34.1%)
  ID-1: /dev/sda vendor: Smart Modular Tech. model: ShanDianZhe-128GB
    size: 119.24 GiB speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2A0
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / size: 62.26 GiB used: 40.58 GiB (65.2%) fs: ext4 dev: /dev/sda4
    label: N/A uuid: a1ca7f56-42eb-467f-9539-09f2cbc76c99
  ID-2: /boot/efi size: 96 MiB used: 43.9 MiB (45.7%) fs: vfat
    dev: /dev/sda1 label: SYSTEM uuid: A017-EF3C
  Alert: No swap data was found.
  ID-1: /dev/sda2 size: 128 MiB fs: <superuser required> label: N/A uuid: N/A
  ID-2: /dev/sda3 size: 54.67 GiB fs: ntfs label: N/A
    uuid: 806E9AED6E9ADAEC
  ID-3: /dev/sda5 size: 800 MiB fs: ntfs label: Recovery
    uuid: E0EA1C23EA1BF50E
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:c821 class-ID: e001 serial: <filter>
  Device-2: 1-6:3 info: Y Media USB Camera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bdc:0320
    class-ID: 0e02 serial: <filter>
  Device-3: 1-8:4 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 7 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 41.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 178 Uptime: 6m wakeups: 1 Init: systemd v: 250 Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1383 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.12

ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 7c:25:da:68:fa:48 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp1s0
       valid_lft 13365sec preferred_lft 13365sec
    inet6 fe80::32b1:f6d4:e26d:7950/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether de:35:f6:2b:38:f9 brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::8e93:a4bb:fb28:254b/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

ip route

default via dev wlp1s0 proto dhcp metric 600 dev wlp1s0 proto kernel scope link src metric 600


# Configuration file for NetworkManager.
# See "man 5 NetworkManager.conf" for details.

I also edited my /etc/resolv.conf


The only difference in behavior I found while using firefox was using the Networkmanager generated /etc/resolv.conf file firefox would fail to load the page quickly while after I edited the file it would attempt to load the page for about a minute before failing.

Also, I tried $ wget but the connection would fail due to timeout. And, surprisingly, I don’t have a ping command.

Would really appreciate any insight or help people can give.

some thoughts:

Has it ever worked before - on this machine?

I would compare the (automatic) config you have now (using the live usb)
with what you have in your system where it does not seem to work.

IPv4 settings should be “Method” automatic - so it gets the DNS server from the router.

What was there before?
Normally, NetworkManager itself is controlling that file and you should not edit it
it will also be overwritten by NetworkManager

I don’t know whether it should be installed by default - obviously it is not.
ping is in:
so, install iputils

perhaps use this as a reference for step by step troubleshooting:

NetworkManager - ArchWiki

Hi, thank you for responding.

This machine and network have not connected before, or rather they seem to connect successfully but I’ve never gained access to the internet. In fact, the machine has failed to connect to the internet on two networks now (recently tried on another friend’s network). The machine has successfully connected to the internet using other networks before, particularly the one it was connected to during installation and one other.

I checked this by right clicking on the wifi icon in the status tray and selecting edit connections. In the window that opens I select the network I’m connecting to, then the IPv4 Setting tab. In the Method drop down, “Automatic (DHCP)” is selected.

Yup, I realized this but was following advice found in a manjaro forum post title “Wifi connected but no internet”. The original file reads:

# Generated by NetworkManager
nameserver ::1

Which is different from that the file reads currently from the live usb

# Generated by NetworkManager

I like your idea of comparing configuration on the live usb to the machine, is this what you mean? From what I can tell the Network Manager settings I can edit through the gui are all the same. Are there other configuration files I should look at?

I’ll also read through the arch wiki post you recommended and see if I can find anything that helps.

I’m totally unfamiliar with reading the meaning of IPv6 addresses
but the former (non working)
nameserver ::1
is an IPv6 address

and the latter (working) is a IPv4 address

Perhaps disable IPv6 to force the use of IPv4?

Of course I don’t know why the results would be different between the live USB and the installed system on the same hardware.

That seems to point that your physical network’s IP address is Your non-working system is using Try to use an IP from your physical network’s space, like

I’m guessing that maybe you have, at some point, edited some system file/s in /etc and your system is setting the IP from there. But it’s just a guess. The thing is that I don’t think the IP you are seeing ( is automatic. It seems to be a manual one. But it’s you (as it’s your system :slight_smile:) who should know where is it coming from…

Anyway, as I said, try to set a manual configuration in your Network Manager with a valid IP address

I just tried disabling the IPv6 connection by setting the method to disabled via the gui. Then I restarted NetworkManager via systemctl and confirmed that IPv6 was still disabled for the connection but the /etc/resolv.conf file still reads

# Generated by NetworkManager
nameserver ::1

Does this mean NetworkManager is still trying to use IPv6? I found an arch article describing how to disable IPv6 as a kernel parameter, do you think it is worth disabling IPv6 that way?

I also tried editing the /etc/resolv.conf as @cfinnberg suggested. I tried,, and but none of those worked. Should the address in /etc/resolv.conf match the address output in the first line from $ ip route?

I did edit /etc/NetworkManager/NetworkManager.conf to disable random MAC addresses, and I edited /etc/resolv.conf to manually add ip addresses, but I haven’t manually edited other files in /etc as I only started using manjaro in Dec and haven’t set up timeshift or another system restore tool yet. If there are particular configuration files anyone can recommend I check or compare to the live usb I will.


or it is falling back on it because IPv4 address assignment doesn’t work for some reason in the installed system

in this case I’d say:

IPv6 - ArchWiki

is the one you want to try - perhaps at first only temporarily
by adding it to the grub command line
by editing it at boot time

It’s strange to me that your router will give out a IPv4 address when you use the USB live system
as is expected and as it is working
but not when using your installed system

as I said as a caveat:
I’m not at all familiar with IPv6 - but I recognize a IPv6 address when I see one

nameserver ::1
is one - it’s not IPv4
but I don’t know what it means
It’s pretty obviously not a very specific network address
(but that is just me, judging IPv6 while just having said that I don’t know about it … :wink: )

Have you perhaps somehow disabled IPv4 in your installed system?
And your router cannot handle IPv6 - so in turn neither one works …?

No… and yes. The main problem here is not resolv.conf but your system’s IP settings. Your computer has an IP address of But your network seems to use 192.168.0.X addresses. This mismatch is what makes impossible to get network. I suspect that your system is not getting IP settings automatically, but somehow they are set manually. You have to force your system to use a proper IP address for your network.

You can check my theory checking other devices (or your Windows) IP settings. They all probably use that 192.168.0.X address.

You also need to set a proper DNS server in /etc/resolv.conf but that is not so important, as you can set a public DNS, like Google DNS server, if necessary. But first you have to get network connectivity at IP level.

1 Like

Pretty sure it’s the loopback, but I don’t know much about ipv6 either. So unless op is running a local DNS server it’s not going to work, but it should be fixed along with the ip address by using a manual config in network manager.

You said you have win10 installed as well and it works and the ISO works.Have you looked at win10’s network as well as the ISO and checked what ip there using.Also make sure the mac add is the same as win.You might also log into the router and check the settings and try rebooting the router.

We did it everyone!

The solution which has worked after a reboot was disabling IPv6 as a kernel parameter. This gives me the correct IPv4 address in /etc/resolv.conf without manually entering the correct ip address.

On my previous post, I don’t think I tried editing the /etc/resolv.conf file with the IPv4 address output from ip route after disabling IPv6 in NetworkManager. This also worked, but NetworkManager would overwrite /etc/resolv.conf attempting to use an IPv6 address (or the loopback?) when I would reconnect, requiring me to manually edit the file again.

As for the ip address I really don’t know where that came from. I initially tried editing the /etc/resolv.conf file to that address because that’s what ip route output, but I don’t know why it was outputting that and by the time of my next post it was outputting the address, which is the current working address.

If anyone has other suggestions to investigate why IPv6 wasn’t working I’m all ears. Otherwise I’ll mark the thread as closed or resolved at then end of the day.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.