NetworkManager: secrets required but not being provided on wired ethernet connection

Hi there!

A while ago my laptop started not connecting to wired ethernets anymore. The plasma-nm gui stays at “configuring interface” until the connection times out. Sometimes I get a popup stating “Incorrect password” and asking to retype it. After doing so, it goes back to “configuring interface” until asking for the password or timing out again.

I already tried connecting manually with nmcli, but i get the same loop there.

> nmcli connection up TEST --ask  
Secrets are required to access the wired network 'TEST' 
Username (802-1x.identity): USERNAME
Secrets are required to access the wired network 'TEST'
Password (802-1x.password): PASSWORD
Secrets are required to access the wired network 'TEST' 
Username (802-1x.identity): USERNAME
Secrets are required to access the wired network 'TEST'
Password (802-1x.password): PASSWORD
inxi -F
  Host: spc Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
  Type: Laptop System: Acer product: Aspire A515-57 v: V1.08
    serial: <superuser required>
  Mobo: ADL model: Ganymede_ADU v: V1.08 serial: <superuser required>
    UEFI: Insyde v: 1.08 date: 04/25/2022
  Info: 10-core (2-mt/8-st) model: 12th Gen Intel Core i5-1235U bits: 64
    type: MST AMCP cache: L2: 6.5 MiB
  Speed (MHz): avg: 1709 min/max: 400/4400:3300 cores: 1: 2082 2: 400
    3: 2955 4: 730 5: 2436 6: 2379 7: 2157 8: 628 9: 400 10: 2177 11: 1710
    12: 2456
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: Chicony ACER HD User Facing driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1: 2560x1440 2: N/A
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.9-manjaro1.1
    renderer: Mesa Intel Graphics (ADL GT2)
  API: Vulkan v: 1.3.279 drivers: intel surfaces: xcb,xlib
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlp42s0 state: up mac: 9c:2f:9d:4d:8e:53
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp43s0 state: down mac: 08:8f:c3:65:a8:fc
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
  IF: enp0s20f0u2 state: up speed: 1000 Mbps duplex: full
    mac: 00:e0:4c:71:a4:8e
  IF-ID-1: br-4745a2be004e state: down mac: 02:42:82:e9:88:54
  IF-ID-2: br-bcaee4fee5f3 state: down mac: 02:42:19:8b:50:b0
  IF-ID-3: docker0 state: down mac: 02:42:70:95:01:60
  Local Storage: total: 476.94 GiB used: 254.69 GiB (53.4%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2450 MTFDKBA512TFK
    size: 476.94 GiB
  Alert: No swap data was found.
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (rpm): N/A

My only trace so far is found in the output of dmesg.

dmesg -I err
integrity: Problem loading X.509 certificate -65
r8168 0000:2b:00.0: Unable to load firmware rtl_nic/rtl8168h-3.fw (-2)
r8168 0000:2b:00.0 enp43s0: Device reseting!
Bluetooth: hci0: ACL packet for unknown connection handle 3837

Some firmware of the realtek gigabit ethernet card seems to be missing.

When trying to find it in the kernel firmware ( there seems to be no rtl8168h-3.fw, only rtl8168h-1.fw and rtl8168h-2.fw.

Am I on the right path, and if so, how can I get the missing firmware -3?
If these are not related, what could be the issue?

Thanks in advance!

No such firmware exists as far as I can see, so I have no idea why it’s trying to load it. Post output of modinfo r8168. Also, is there a reason why you’re using the seperate r8168 driver instead of the kernel r8169 driver that works for most people? This is my ethernet

$ inxi -Na
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 2a:00.0
    chip-ID: 10ec:8125 class-ID: 0200

and the r8169 driver uses rtl_nic/rtl8168h-2.fw

$ modinfo r8169 | grep rtl8168h
firmware:       rtl_nic/rtl8168h-2.fw
1 Like

I actually don’t know why the r8168 driver is used. I never installed it explicitly.

Here’s the output of the modinfo command:

modinfo r8168
filename:       /lib/modules/6.6.32-1-MANJARO/extramodules/r8168.ko.xz
version:        8.053.00-NAPI
firmware:       rtl_nic/rtl8168fp-4.fw
firmware:       rtl_nic/rtl8168fp-3.fw
firmware:       rtl_nic/rtl8168h-4.fw
firmware:       rtl_nic/rtl8168h-3.fw
firmware:       rtl_nic/rtl8168h-2.fw
firmware:       rtl_nic/rtl8168h-1.fw
firmware:       rtl_nic/rtl8168ep-3.fw
firmware:       rtl_nic/rtl8168ep-2.fw
firmware:       rtl_nic/rtl8168ep-1.fw
firmware:       rtl_nic/rtl8168g-3.fw
firmware:       rtl_nic/rtl8168g-2.fw
firmware:       rtl_nic/rtl8411-2.fw
firmware:       rtl_nic/rtl8411-1.fw
firmware:       rtl_nic/rtl8168f-2.fw
firmware:       rtl_nic/rtl8168f-1.fw
firmware:       rtl_nic/rtl8168e-4.fw
firmware:       rtl_nic/rtl8168e-3.fw
firmware:       rtl_nic/rtl8168e-2.fw
firmware:       rtl_nic/rtl8168e-1.fw
firmware:       rtl_nic/rtl8168d-2.fw
firmware:       rtl_nic/rtl8168d-1.fw
license:        GPL
description:    RealTek RTL-8168 Gigabit Ethernet driver
author:         Realtek and the Linux r8168 crew <>
srcversion:     5768E2ABC969ACBA42BA843
alias:          pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*
alias:          pci:v000010ECd00002600sv*sd*bc*sc*i*
alias:          pci:v000010ECd00002502sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008161sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
retpoline:      Y
name:           r8168
vermagic:       6.6.32-1-MANJARO SMP preempt mod_unload 
parm:           speed_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           duplex_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           autoneg_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           advertising_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           dynamic_aspm:int
parm:           aspm:Enable ASPM. (int)
parm:           s5wol:Enable Shutdown Wake On Lan. (int)
parm:           s5_keep_curr_mac:Enable Shutdown Keep Current MAC Address. (int)
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           timer_count:Timer Interrupt Interval. (int)
parm:           eee_enable:Enable Energy Efficient Ethernet. (int)
parm:           hwoptimize:Enable HW optimization function. (ulong)
parm:           s0_magic_packet:Enable S0 Magic Packet. (int)
parm:           dynamic_aspm_packet_threshold:Dynamic ASPM packet threshold. (int)
parm:           disable_wol_support:Disable PM support. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)

Somehow the driver seems to try to use not only -3, but also -4:

firmware:       rtl_nic/rtl8168h-4.fw

If it could help, how can I disable the r8168 driver, and where do I get the r8169 driver?


r8169 seems to be installed as part of the linux66 kernel drivers, so the only question remaining is:

How do I change the running driver from r8168 to r8169?

blacklist the r8168 driver.

create a file, as root in /etc/modprobe.d/blacklist.conf
blacklist r8168



su -c "echo 'blacklist r8168' > /etc/modprobe.d/99-blacklist.conf"



Thanks for your reply!

I just removed it using mhwd before i read your answer, and now it seems to automatically us the r8169 driver.

inxi -N
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169

Sadly, the original problem - the wired connection getting no secrets - still persist.

I now removed the connection and re-set it up again, and now it works! (didn’t change any credentials).

So I guess

  1. the new driver works fine,
  2. the old one was indeed the problem and
  3. the connection just needed an additional reset.

Therefore I mark @MrLavender’s answer as the solution.

Thanks for your help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.