NetworkManager reports Internet is down, even though it's not

It appears NetworkManager cannot connect to, even though I can access it in a browser, and every other website is working. I am geting this notification.

Both work here … Are you behind some VPN/proxy ?

Working fine for me. Something firewalling you ?

this is a local problem of your connection or a problem of your service-provider.

Then why do my connection and my service provider work fine otherwise?

No, I am not using a VPN, firewall, or proxy.

What is really odd about this is that I can do this in the terminal:

$ curl
NetworkManager is online

But NetworkManager still reports that my connection does not have access to the Internet.

Out of curiosity: grep "^uri" -rs {/usr/lib,/etc}/NetworkManager

$ grep "^uri" -rs {/usr/lib,/etc}/NetworkManager

I have tried changing the uri to and using /etc/NetworkManager/conf.d/20-connectivity.conf with no success. I deleted that file, letting it fall back to

What do you get if you call it manually:
nmcli networking connectivity

$ nmcli networking connectivity

Is it the same if you force a refresh?
nmcli networking connectivity check

It still says limited. So why can I manually retrieve with curl, but NetworkManger cannot?

Only thing that comes to mind is failing to resolve the domain.
Yet everything else works, I assume /etc/resolv.conf has correct values.
Is /run/NetworkManager/resolv.conf the same?

I use systemd-resolved. This issue only started after one of this week’s testing updates. This might be a bug in NetworkManager 1.38.

I just tried a different wifi network and still have this issue. I can fully access every web site, but NetworkManager claims I have limited connectivity.