Network-Speed very low + Network adapter down / not available

Dead Manjaro-Community,

I have the following problem:

Description. Since 09/06/2023, no LAN/network is available after reboot (unless UEFI trick is applied, see below). Internet speed is only ~10% (about 10 mbit of 100 mbit), absoulut lame. See screenshots.

I do not want to flood you with information I have tried everything the last few days, but now some:

  • A temporary ancient stick with WLAN always works

  • Computer is connected to the router via network cable. I threw away the old cable and put a brand new cable on it, that was my first guess of the error. But it wasn’t.

  • I tested the Fritz-Box (router) with another device (cell phone, only WLAN on). Speed fully there, no problems. Various speedtest on the computer very slow and surfing feels extremely lame

  • with Timeshift I have reset the settings to 24.08., so before the last big update. Error is always then also there. So probably nothing to do with system changes / software change in the given period of time

  • What helps if the LAN connection is not available: UEFI: Activate network stack. Then you can also reboot ~2-3 times (and also disable the stack). But eventually the problem occurs again. Due to trial and error I have a medium number of reboots behind me and of course it’s getting annoying.

  • updated the latest BIOS from ASUS. Tried installing the proprietary network card driver via Manjaro hardware config, it gave an error the first time. Result: it kicks the connection / card / LAN —> reboot required. Tried 2 times. Second time installation works, but after reboot no connection works. Driver removed, restarted and it works again.

I have no idea what the cause is now. Maybe someone has an idea and can help me.

Thanks in advance.

Uninstall the r8168 driver module by way of the Manjaro Settings Manager and use the in-kernel r8169. :wink:

It is not installed. Maybe I understand someting wrong? Thanks for your help!

Your screenshot here — and this is why you should copy and paste instead of inserting terminal screenshots, because now I have to include it in the quotes — says otherwise… :arrow_down:

Check if you have r8169 blacklisted in /etc/modprobe.d/. If it’s blacklisted, remove it from the blacklist.

Sorry, don’t know how to get this information better in a text. :frowning: I see there no blacklisting. Thanks.

Again, please do not post screenshots of things that can be copy/pasted with the mouse.

Your inxi screenshot shows that you are running the r8168 driver module. Uninstalling that module does not remove it from the running kernel.

If the r8168 module has been uninstalled and you don’t have a blacklist on r8169, then you must reboot in order to load r8169. But before you do that, perhaps it is best to rebuild your initcpios and update your boot loader… :arrow_down:

sudo mkinitcpio -P
sudo update-grub
sudo systemctl reboot
1 Like

OK, I did the commands & rebooted.

inxi -Fza
  Kernel: 6.5.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.5-x86_64
  Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME B550-PLUS v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3205
    date: 08/14/2023
  Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1617 high: 4301 min/max: 400/5288 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 4301 2: 4290 3: 400
    4: 4297 5: 400 6: 400 7: 400 8: 4297 9: 400 10: 400 11: 400 12: 400
    13: 4297 14: 400 15: 400 16: 400 bogomips: 137658
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow mitigation: safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-1 empty: DP-1
    bus-ID: 07:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 32.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 211 s-size: 462x260mm (18.19x10.24")
    s-diag: 530mm (20.87")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Sony TV 00 serial: <filter>
    built: 2019 res: 3840x2160 hz: 60 dpi: 59 gamma: 1.2
    size: 1660x934mm (65.35x36.77") diag: 1905mm (75") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.54 6.5.1-1-MANJARO) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.5.1-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.79 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp5s0 state: up speed: 10 Mbps duplex: full mac: <filter>
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  System Temperatures: cpu: 44.6 C mobo: N/A gpu: amdgpu temp: 32.0 C
  Fan Speeds (rpm): N/A
  Processes: 519 Uptime: 3m wakeups: 4 Memory: total: 32 GiB note: est.
  available: 30.65 GiB used: 4.29 GiB (14.0%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1801 pm: pacman pkgs: 1798 libs: 476 tools: pamac,yay pm: flatpak
  pkgs: 0 pm: snap pkgs: 3 Shell: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.29

That’s not looking good. With that adapter and that driver — you are using the in-kernel r8169 driver now — you should have a theoretical maximum speed of 1 Gbps.

I suspect that the cause of the problem is to be found outside of your computer, i.e. your router, your modem, or maybe your bandwidth has been capped by your ISP. :thinking:

It’s definitely a hardware problem it should be connecting at 1000 Mbps. I have exactly the same device (see chip-ID) on a MSI MAG B550 TOMAHAWK and no problems at all, so do many others (it’s a widely used chip).

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

Try a different port on the router. Try a different wired device at the PC end if you have one. And I know you said you replaced the cable but with what? There’s plenty of cheap junk cables out there which don’t live up to their Cat 5e/6 claims.

1 Like

My fritzbox made an auto-update at this time.

FRITZ!OS: 7.57
Installiert am: 07.09.2023 2:02

and now I see:

LAN 1 mit 10 Mbit

but the all 4 ports are on 100 Mbit. I’ll try the 1000 Mbit mode.

OK, AVM (fritzbox) screwed it up. Solution was setting the ports to 1 Gbit then it worked perfectly. I set it back to 100 Mbit and still working at 100 Mbit and not more 10 Mbit. Speedtest is fine now! :slight_smile:

Now I have to see the days if finding the network also had something to do with it or if that is also solved.

Please therefore do not close, I will update the days again.

Thank you!

These days, you have to set it to 1 Gbit. 100 Mbit connections are outdated.

Honestly I have 100 Mbit internet and I personal don’t see a difference, even if I lost some Mbits, I like to save the power. :wink:

It doesn’t save any power. On the contrary: you are creating a bottleneck that feeds back onto your CPU as a local denial of service. :man_shrugging:

1 Like

The power difference between 100Mb and 1000Mb ethernet is less than 5W. There are numerous better ways to save energy than making problems for yourself like this, in my opinion.

1 Like

I respect your both opinion and want to say a big thanks again to you. :kissing_heart:

I just restarted, then

UEFI: Deactivate network stack

and restarted now 3 times. The network is always been found and found immediately, not with 5 sec search time like before.

Seems to be fixed all.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.