Network speed on Manjaro slower than Windows (70mbs vs 200mbs)

[ranvir@ranvir-pc ~]$ inxi -Fxz
System:    Kernel: 4.19.152-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B350-PLUS v: Rev X.0x serial: <filter> UEFI [Legacy]: American Megatrends 
           v: 3401 date: 12/04/2017 
CPU:       Topology: 6-Core model: AMD Ryzen 5 1600X bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86227 
           Speed: 1853 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 1882 2: 1881 3: 1838 4: 1830 5: 1882 6: 1882 7: 1882 
           8: 1893 9: 3176 10: 3087 11: 1946 12: 1867 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Tul 
           driver: amdgpu v: kernel bus ID: 07:00.0 
           Display: x11 server: X.Org 1.20.9 driver: amdgpu FAILED: ati unloaded: modesetting resolution: 1: 1920x1080~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.27.0 4.19.152-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.8 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Tul driver: snd_hda_intel v: kernel 
           bus ID: 07:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 
           Device-3: SteelSeries ApS SteelSeries Arctis 7 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2:3 
           Sound Server: ALSA v: k4.19.152-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI 
           port: f000 bus ID: 03:00.0 
           IF: enp3s0 state: up speed: 100 Mbps duplex: half mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 91.06 GiB (4.3%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB 
Partition: ID-1: / size: 113.66 GiB used: 36.16 GiB (31.8%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 575.74 GiB used: 54.90 GiB (9.5%) fs: ext4 dev: /dev/sdb1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 35.6 C mobo: N/A gpu: amdgpu temp: 35 C 
           Fan Speeds (RPM): cpu: 0 gpu: amdgpu fan: 1117 
Info:      Processes: 254 Uptime: 42m Memory: 15.66 GiB used: 3.42 GiB (21.8%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1266 Shell: Bash v: 5.0.18 inxi: 3.1.05 

So I believe the issue to be the fact my RTL8168 is limited to 100mbs but I have no idea how to change it. I searched around on google and couldn’t find anything helpful. As stated in the title I can about 200mbs on windows but on 70mbs on Manjaro.

What’s the output of ethtool enp3s0?

the command isnt be recognized dont know what im typing wrong? its probably something stupid
[ranvir@ranvir-pc ~]$ ethtool enp3s0
bash: ethtool: command not found

In that case please install the ethtool package first.

[ranvir@ranvir-pc ~]$ ethtool enp3s0
netlink error: No such file or directory
Settings for enp3s0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        MDI-X: Unknown
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

you can try to change the settings of your wired network (inside plasma) for link negotiation to “automatic” to see if it will detect and change to the actual 1000mbps (if your router port is a 1000mbps etc).
I don’t really understand the difference between “ignore” and “automatic”.

Could you check again with a plugged-in cable?

Using the driver r8169 shows me:

Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full


Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                     100baseT/Half 100baseT/Full

So fully understandable that my card can do 1000Mbit/s but my Router doesn’t offer it.

Maybe the issue here is that you use TP and the driver only offers this one… while i use MII.

Supported ports: [ TP	 MII ]
Port: MII

PS: I can also install r8168 (through mhwd aka Manjaro Settings),but r8169 works perfectly for me…

Btw… you can set the speed manually with:

sudo ethtool -s  enp3s0 speed 1000 duplex full

for example.

Thanks that did the trick

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.