Network problems with Mullvad VPN


I’m having problems with my internet connection sometimes (often) disconnecting, while using Mullvad VPN. Problem always gets fixed when I reconnect, but it’s really annoying. I have feeling the problem has something to do with DNS, because the errors always say something linked to hostname.

Whenever I’m going to it doesn’t let me connect until I reconnect. If I try to go to after that, it does the same thing. Finally, if I go to again same thing happens. Don’t know if this helps but it’s really weird. The loop just keeps happening everytime and it’s also same thing for

Can you upload the errors/logs for someone to look at. If you are using mullvad from the aur the maintainer is a member of the manjaro team

I don’t know where I can get Mullvad’s logs from

And for example right now I can connect to all sites but Archlinux . org which gives me error:

"Hmm. We’re having trouble finding that site.

We can’t connect to the server at bbs . archlinux . org."

When I reconnect Mullvad it works like a charm again…

Hmm im using mullvad and had zero issues connecting to archlinux. Is it just the one site? And how are you using mullvad? Did you install from the aur?

It’s happening randomly to some sites and sometimes to the whole OS. I installed it straight from AUR and I’m using the GUI.

It was happening lot more often when I didn’t have the option “Enable IPv6” enabled, now it’s happening only sometimes. Windows version worked nicely when I used it and didn’t have any problems.

Maybe hit up @Yochanan and ask him for any ideas. Im lazy and use the gui

Thank you anyways, have a good one.

There’s nothing in the pinned comments on

but might be worth asking there if anyone else has similar issues.

I’m using GUI as I stated on my comment and I actually already commented there but thanks :slight_smile:

If you are using wireguard, do you have wireguard-tools installed?
It looks like there may be some instability due to upgrades on certain servers:


Hi! Installing wireguard-tools seems to fix the problem atleast for now, I’ll keep this thread open for sometime to see if everything stays stable. Thank you!

E: Still having the same problem…

EE: I’m pretty sure I hadn’t enabled Mullvad Daemon service… let’s see now.

EEE: Nope.

Welcome to the forum! :wave:

See Mullvad’s FAQ page.

The AUR comments page is for issues with the package, not for technical support. You’re in the right place here, though. :wink:

Mullvad VPN has wireguard-go built-in, there’s no need to install wireguard-tools.

For WireGuard, we use the standard Linux kernel implementation when available. Otherwise we use wireguard-go.

Mullvad VPN | Privacy is a universal right

It’s enabled by default during install. You can check the status:

systemctl status mullvad-daemon
1 Like

Now I even lost connection to my whole internet and I think the problem is with my B550 mobo, which apparently has had a lot of problems with Arch and Manjaro…

Forget about using a VPN for the moment then. Uninstall Mullvad VPN and create a new Network topic if you need help making sure your connection is stable to begin with.

1 Like

Sorry for necro, but I’ve been facing the same issues for a while now, since a specific update (and strangely enough, it has also been somehow happening on mobile, though in a slightly different way).
It most definitely has to do with some DNS stuff, since it always fails with resolving hostnames, and since all connections initiated before it eventually confuses itself work just fine, just new ones are foobared.
I will have to reach out to Mullvad support and see what’s going on, I suppose.

I had it working on Arch with just NetworkManager and their supplied configurations.
Not their dedicated App.

Now, currently I use Mint - and their App.

It did always work perfectly.

There is an AUR package to build/adapt their App to Arch/Manjaro.

You’ll have to tell them, as well as us here, your specific problem, symptoms and system configuration …

Generally I suggest people use systemd-resolved but no one ever listens :person_shrugging:

mmm I’ll try that, I suppose. Still, I find it odd it stopped working after an update, despite it having worked for very long without any issues, while also no longer working fine on mobile as well.

You didn’t specify the manner in which it was “not working” - the actual info …

If you used the AUR to istall their app - it may need to be rebuilt after system updates - after the “base” system changed due to updates.

Who knows?
I don’t. :wink:

There is no concrete info here.