Network printer Epson ET-2851 won't print - solved

Particularly stubborn printer here…
The ET-2851 is hooked up to an iMac via USB (printer’s WiFi module is broken), printer sharing is activated and works (I can print to that printer from my Windows-PC).
Did the following steps so far:
-activate Avahi (to see printer in KDE printer settings)
-install Epson printer driver from AUR (escpr, not escpr2)
-install printer in KDE’s printer settings
No problem so far, the printer shows up, I can even see the ink levels in KDE’s settings and CUPS (localhost:631) also shows the printer with correct settings (output from lpinfo and the printer URI in CUPS match).
However, whenever I try to print something, the printer wakes up, quickly flashes “Printing” on its display and then immediately stops, as if it never receives any data to print. I have the feeling that this is just some very simple setting I am overlooking… Thanks in advance for any help!

Edit: Solved, though I am not sure how. I just re-installed the Epson printer driver on the iMac, deleted all printers on the iMac and the Linux PC, then reinstalled printers and it works now. I have no idea why, though.