Network connections missing after Pamac update

I am running Manjaro KDE on a few older servers in my garage. I run some various Docker containers on these servers and manage them with Kubernetes via Rancher. Yesterday, I attempted to add a WireGuard docker container to one of my servers. I spun it up in Rancher following a tutorial, and to my dismay, the service did not work due to my ISP not giving me a static IP address. I removed the container from Rancher and continued on. Later in the day, I installed a Firefox update as well as 5 updates to Pamac via the Add/Remove Software app (specifically, pamac-common, pamac-cli, pamac-flatpak-plugin, pamac-gtk, and pamac-snap-plugin). After the updates finished, I rebooted the server. Upon rebooting, both of my network connections have disappeared from the Network Connections popup in the system tray and the network connections preference pane in the Settings app. Additional reboots did not fix the issue, nor did fully shutting down and turning back on the server.

For context, the server has two ethernet ports which showed up as Wired connection 1 and Wired connection 2 in the Network Connections popup. Both hardware interfaces appear when I run ip link show. I’m wondering if the docker container might have done something, as it required I give it the NET_ADMIN and SYS_MODULE capabilities, as well as bind-mount the /lib/modules/ directory. I used the Linuxserver.io image for WireGuard, so I have a hard time believing that it would’ve caused any issues, as the interfaces worked fine while the container was running and after the container was removed. Additionally, I don’t see any wg connections when I run ip link show.

A final weird thing: if I add a new network connection in the Settings app and link it to the first ethernet interface, it connects to my router and begins working, but then Wired connection 1 and Wired connection 2 magically appear again. Neither will connect to my router, even if I disconnect/remove the network connection I added. Additionally, the connections deactivate and then attempt to reactivate every 2 minutes or so until I reboot the server, which causes Kubernetes to go haywire and keep duplicating virtual network interfaces.

Where should I begin? If the docker container caused issues or somehow made the connections unavailable, how would I be able to see that from the terminal and undo it? If the docker container didn’t cause issues, could a Pamac update really affect my network connections? I have a USB to ethernet adapter that is working, so I can download packages/connect to the internet to fix this if needed. Thanks.

I have no idea why or how this worked, but I was able to fix it by doing the following:

With a new connection added, both of the old connections appeared, although neither would connect. I noticed that the priority for both connections was set to -100 instead of 0. Upon setting the priority for both to 0, deleting the new connection and rebooting, ethernet networking is working again! I also noticed that my ethernet interfaces are no longer eth1 and eth2, but instead are enp1s0 and enp2s0. I did update the linux kernel to 5.10 from 5.9 a week or so ago, so I’m guessing this name change happened then. I wonder if this had something to do with it as well.