Network connection missing in Kernel 6.8rc7-1

After updating the kernel to 6.8rc7-1 my network card no longer appears. Network manager shows no connections and my network card: “06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)” No longer shows up in lspci.
It was working normally in 6.8rc6
I’m running Manjaro unstable tree.
Is this a kernel bug or a kernel module missing? How would I go about finding out what is wrong.
I’ve now reverted to Kernel 6.6.21-1 LTS. Network is working there just fine.

It can be a regression if it worked on RC6 of that kernel series …

Maybe it is a regression. I couldn’t find anything specifically related to the r8169 driver here: kernel/git/torvalds/linux.git - Linux kernel source tree
How would I go about diagnosing the issue and providing useful information? Where could I report a kernel regression?
It’s a very common hardware configuration so I don’t suppose it will go unnoticed for long, with or without my help. I’m just keen to learn more on how to deal with this sort of thing.

Can confirm this problem is solved in kernel 6.8.0-1