Neomutt can't connect to my email server

Neomutt used to work for me in Ubuntu but when I switched to Manjaro i3 I can’t connect to my mail server. I’m not sure if the syntax in my config is the reason or a firewall is blocking it.

Here is my config ~/.config/mutt/muttrc

set folder = "imaps://" 
set imap_user = ""
set imap_pass = "password"
#set imap_check_subscribed = yes
#set imap_list_subscribed = yes
set timeout = 15
set mail_check = 90
set imap_keepalive = 180
#unset imap_passive

set smtp_url = "smtp://"
set smtp_pass = "password"
set ssl_starttls = yes

set spoolfile = "+INBOX"
#mailboxes = "+INBOX"
#set record = "+INBOX.sent"

This is the response when the connection fails:

Unable to open mailbox imaps://

Have you tried

set imap_user = "xxx"

I have accounts that require just the username; others require the whole addess (user@provider).

I tried but it doesn’t work. I also installed other email clients but none of them is able to connect to the server. I suspect it has some thing to do with gnome-keyring but I don’t know how to enable it for neomutt.

I am fairly certain neomutt will work the same

Most software firewalls only blocks incoming traffic - so unless you have setup rules for outgoing (targeting the destination port) as well - this is most likely not the case - but nonetheless I think you are looking at a network configuration error. Even though you initially strikes me as a proficient Linux user - here is a link to some basic troubleshooting.

Is the server a pop3 only server?

EDIT 2021-05-24T07:42:00Z

For the sake of testing your issue - I installed neomutt - and setup a config like yours - of course adjusted for my use - it worked OOB.

So either you are having a connection issue or as @mithrial suggests - in below comment - maybe the certificate is the issue.

If it is really your server, you might check the logs there what went wrong. Maybe you’re using an outdated or self-signed certificate?

1 Like