Nemo filemanager does not handle moving of links properly anymore

I like to save browser links in folders on certain topics by just dragging the web link from the browser into the folder window within nemo file browser … worked fine until the last update “a few weeks ago”.

Now I can not move (drag-drop) or copy-paste the links any more (which are normally just 200-300 Bytes text files), as nemo not moves this text file into the destination but instead downloads the whole (big, static) html webpage and puts that into the destination folder … super annoying and of course not what I want.

What browser are you using?

Does not matter, makes no difference. Latest Firefox, (ungoogled) Chromium to create the link files by drag-drop.
Thereafter , when moving the link (text) file, the problem comes up …

It depends on the file manager e.g.

  • dolphin accept a drag’n’drop → asks for filename → the content is the url
  • pcmanfm does not

So if the nemo filemanager no longer accept the action or has changed the operation itself - it is an upstream decision - the developers of the filemanager.

I worked with nemo until a few weeks ago.
Maybe it was not intentional ?
I"ll create an issue on github …

Did you check the open issues? your issue has already been marked as duplicate …

I did a quick check, but might have missed the other one …

I’m having this issue as well with Firefox links, not with any other ones. Nemo responds with “this operation is not supported”.

The post from linus-aarhus mentions that this issue report is marked “duplicate”, but unfortunately doesn’t mention of which one.

Has a fix or work-around been found already? Could it help, perhaps, if I downgrade Nemo, and how can I do that?

I’m using the Cinnamon DE, freshly installed and upgraded 3 days ago, using EFI.

And why, by the way, does the forum report that it’s August 2 today?? It’s the 25th now…

EDIT: If I scroll down 'till below my post, the date changes into the correct one.