Nemo doesn't mount ntfs


I have installed Nemo in Manjaro Gnome for several years (dual boot win). There are several ntfs drives on the PC. Until recently I was able to mount all these ntfs drives in Nemo by mouse click if needed. The name of the drives is available. Now one (!) of these drives is no longer mounted and an error is displayed. See attachment. Quick start is deactivated on the Windows start partition.

I can still successfully mount this drive manually:

sudo mkdir /run/media/tom/files
sudo mount -t ntfs-3g /dev/sdb1 /run/media/tom/files

What is the reason?



echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf

This is just a fix, it could be that your FS on the mentioned drives is marked dirty by Windoze, which could happen if not properly shut down, with other words if Fast startup is enabled.

Package ntfs-3g should be installed.


Try this… :point_down:

sudo bash -c 'echo "blacklist ntfs3" > /etc/modprobe.d/disable-ntfs3.conf'

Explanation: The new kernels now use the in-kernel ntfs3 driver, which often fails. When you are mounting them manually, you are using ntfs-3g as the driver, which is the one that works. By blacklisting ntfs3, you make sure that it’ll always use ntfs-3g. :wink:

Also, if you are dual-booting with MickeySoft Wintendo™, make sure that “fast startup” is disabled. It doesn’t properly shut down Wintendo and leaves your filesystems in an open state, which Linux detects as potential filesystem damage.


Thank you. It is working this way! I wrote it above, but I named it “quick startup”. It was disabled.

1 Like

The reason you are still able to mount the drive manually is likely due to using ntfs-3g, whereas ntfs3 (a kernel driver) is now the default used when mounting these drives automatically. Lately, there have been some issues using the kernel driver.

Blacklisting the kernel driver, using either method suggested above by @Wollie or @Aragorn, should immediately allow ntfs-3g (which you already have installed) to assume the role of automounting these drives, as before.


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.