Nemo actions not working in XFCE

I’m trying to get Nemo actions to work but they don’t execute when clicking on them.

I placed a file in my /home/$USER/.local/share/nemo/actions folder containing the following:

[Nemo Action]
Name=Reduce Image 50%
Comment=Reduce the size of the image by 50%
Exec=ffmpeg -i %F -vf scale=iw/2:-1 %F

And ran gsettings set org.cinnamon.desktop.default-applications.terminal exec xfce4-terminal as advised.

Running nemo in debug mode gives me the following when clicking on it:

(nemo:16223): dconf-DEBUG: 22:20:11.469: watch_fast: "/org/cinnamon/desktop/applications/terminal/" (establishing: 0, active: 1)
(nemo:16223): dconf-DEBUG: 22:20:11.470: unwatch_fast: "/org/cinnamon/desktop/applications/terminal/" (active: 2, establishing: 0)
xfce4-terminal: Unknown option "--"

Can anyone help me with this?

you need to watch your reserved characters.
use %%F

with *.desktop files, if it’s not a strait command, it’s better to create a script in your ~/bin, make sure you use full path to the script for the Exec=
*.desktop files are very picky about commands, it basically just wants a path: /home/you/bin/


Nope, that didn’t work

even when you put it in a script?

try a simpler command:
mogrify -resize 50% %f

use “$@” in scripts.

1 Like