Need to manually run `sysctl -p` every time for Dropbox to work

Lately, every time I boot I need to close Dropbox, which autostarts on system boot but fails to sync due to fs.inotify.max_user_watches being too low. I have it already set in /etc/sysctl.conf but apparently sysctl won’t invoke it before Dropbox is launched, so I have to do it manually, every time, by stopping Dropbox, then running

sudo sysctl -p /etc/sysctl.conf

then launching Dropbox again.

Is there a way to fix this?

You really do not provide a lot of information for us to go off of right now. We don’t know your DE, Kernel or anything.

ls /etc/sysctl.d/

1 Like

right, sorry about that. But increasing the value in /etc/sysctl.d/50-max_user_watches.conf solved it. Thanks!

You should instead delete that file and the sysctl.conf file you created. If you told me that you were running KDE and the approximate time you installed your system, I could’ve immediately pointed out what the issue was. How? Because of this.

Also, why did you give yourself the solution tag :thinking:

Yes, I’m running KDE and installed it in mid-june this year.

If you point out the issue I’ll be more than glad to hear it : ). I don’t quite understand the reason (I’m not that proficient, just a regular user).

I tagged my post as solution to pinpoint how I fixed it. Would you please provide some details so I can tag yours instead?

This is my output to inxi --full

System:    Host: p53 Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20QNCTO1WW v: ThinkPad P53 serial: <superuser/root required> 
           Mobo: LENOVO model: 20QNCTO1WW v: SDK0J40697 WIN serial: <superuser/root required> UEFI: LENOVO 
           v: N2NET37W (1.22 ) date: 04/28/2020 
Battery:   ID-1: BAT0 charge: 82.2 Wh condition: 82.2/90.0 Wh (91%) 
CPU:       Topology: 6-Core model: Intel Core i7-9850H bits: 64 type: MT MCP L2 cache: 12.0 MiB 
           Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU106GLM [Quadro RTX 3000 Mobile / Max-Q] driver: nvidia v: 440.100 
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia resolution: 1: 1920x1200~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: Quadro RTX 3000/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
           Device-2: BEHRINGER type: USB driver: snd-usb-audio 
           Device-3: AKAI Professional M.I. type: USB driver: snd-usb-audio 
           Sound Server: ALSA v: k5.8.16-2-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e 
           IF: enp0s31f6 state: down mac: 00:2b:67:8d:1f:2a 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi 
           IF: wlp82s0 state: up mac: 9c:fc:e8:3c:cb:b1 
Drives:    Local Storage: total: 953.87 GiB used: 144.16 GiB (15.1%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBQNTY-1T00-1001 size: 953.87 GiB 
Partition: ID-1: / size: 444.74 GiB used: 144.13 GiB (32.4%) fs: ext4 dev: /dev/nvme0n1p5 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 55.0 C mobo: 41.0 C gpu: nvidia temp: 42 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 289 Uptime: 14m Memory: 30.98 GiB used: 2.95 GiB (9.5%) Shell: Bash inxi: 3.1.05