Need to change path for installing packages

Four??? :astonished: :exploding_head:

There should be only one, and every other line that looks similar should start with a comment (#). :face_with_raised_eyebrow:

Lines starting with # or ## are comments. Only the line that actually starts with the word HOOKS= is the one you should modify.

just to be sure everything is on right place,

now… systemctl reboot?

[manjaro ~]# [ ! -d /mnt ] && mkdir /mnt
mount -t ext4 /dev/sdb1 /mnt
rm -rf /mnt/usr/*
mount: /mnt: /dev/sdb1 already mounted on /mnt.
       dmesg(1) may have more information after failed mount system call.

[manjaro ~]# 
[manjaro ~]# umount /mnt
umount: /mnt: target is busy.
[manjaro ~]# 

Are you sure that’s the right partition? I would have expected the new partition to be /dev/sdb2 and your /home to be /dev/sdb1. :thinking:

Try the following… :arrow_down:

sync && cd / && systemctl reboot

I though it was ok, once the target is busy had already showed up…

cp: cannot create directory '/run/initramfs/': No such file or directory
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck.

sh: can't access tty; job control turned off
[rootfs ]# _

but yes, /dev/sdb1 was my ssd

edit: i presume i must reinstall everything?

I’m sorry btw

Methinks somebody used the wrong partitions… :frowning_man:

Well, I guess it’ll be a reinstall then, because I have no idea what you may have done to get you into this mess, and by consequence, even less of an idea how to get you out of it again. :man_shrugging:

Look at it from the bright side: at least now you can get to do it right from the start by putting your entire root filesystem on the HDD and using the SSD only as extra storage. :thinking:

1 Like

it would nice though if i could use the ssd for booting and that partition we made for /usr :sunglasses:

but thats seems too much for 20 days linux user

Well, if I had known that you were an absolute novice, then I would not have dragged you into such an elaborate technical maneuver. Then I would simply have advised you to reinstall.

Still, it’s commendable that you tried to see it through, which tells me you’re genuinely interested in the system and open to learning — most of the newbies we get are consumers with unrealistic experiences and often also equally unrealistic demands. You will by now also have learned quite a bit more about the system than most of our other newbies do in years.

I’m sorry things didn’t work out this time. I always vicariously enjoy it when people manage to solve their problems with my advice, and I’m equally sad for them when it doesn’t work out. :frowning_man:


I pretend to use only linux and I don’t see myself using windows anymore, so that means I’ll need to learn. :smiling_face: Thank you for your time!

And also, before reinstalling everything: there’s no way I can access my computer files, there is?

1 Like

Well, yes, there is. You could boot up from the installer in live mode, as before. Then, mount your /home partition, and then perhaps plug a USB stick into another USB port, and copy over the data to the USB stick.

But: be advised that if the USB stick has an ntfs or FAT-based filesystem on it, then the permissions and ownership of your files will all be lost, because those Microsoft filesystems do not support POSIX permissions and file ownership.

You’ll probably need to create a second mountpoint in the live environment for the additional USB stick, but that’s as easy as… :arrow_down:

sudo su -
mkdir /usb
mount -t ext4 /dev/sdb1 /mnt
mount -t auto /dev/sdc1 /usb
cp -RPpv /mnt/maria/* /usb/

The above of course assuming that…

  • your /home was indeed /dev/sdb1 and not /dev/sdb2 — which is where I think your endeavor above went wrong — and…
  • your user name on your system is maria.

My /home was /dev/sda1.
The partition I made /dev/sda2
My ssd /boot was /dev/sdb1

Then this is the one you have to mount to /mnt in the live session, and then the rest of the commands can be issued as I gave them to you.

Of course, if you have a NAS in your network, that would perhaps be even better for making backups. And if you don’t, then you should consider a good backup strategy either way — maybe an external SSD or HDD; they’re not that expensive anymore these days. :wink:

in my selection for the HD being manjaro boot,
no manual partition, but simply doing what’s easier
i believe later one day i’ll do a better separation of directions

but why the ssd is going to be created as MSDOS?

Probably because you’ve set up your UEFI firmware to boot in legacy BIOS emulation mode.

Legacy BIOS emulation does support a GPT partition table, but it takes a special precaution — i.e. you need to create an extra (and unformatted) partition of about 3 MiB in size and marked with the bios_grub flag — because of how the legacy-BIOS-boot version of GRUB works on GPT. Without that empty partition, GRUB would overwrite your partition boundary and damage your filesystem.

The option to do all this is available if you opt for custom/manual partitioning, but with the automatic partitioning, Calamares will default to an MBR partition table on systems that boot in legacy BIOS mode — it’s easier — and a GPT partition table on systems that boot in native UEFI mode.

1 Like

where / should this 3MiB partition should be mounted?

edit: also i tried to change for uefi (i remembered i got problem because of windows and changed it to bios)

but i’m getting stuck at waiting for 1 module at the very first step of installation

that’s strange i’m having problems at installation

Nowhere. It doesn’t have a filesystem on it, so you cannot mount it. It is merely a reserved area of the drive for GRUB’s intermediary stage, and at that point in the boot process, GRUB still doesn’t even understand filesystems, so it reads the raw disk blocks. It doesn’t even matter where on the drive you create it, as long as it’s about 3 MiB in size and has the bios_grub flag set.

When you install GRUB on a GPT-partitioned drive that boots in legacy BIOS mode, then the first stage of GRUB will be installed in the MBR of the drive — in your case, that would be /dev/sda. However, that’s just the stage that intercepts the legacy BIOS boot routine.

This first stage will then look for a 1.5 stage, which holds the filesystem drivers, but on an MBR-partitioned drive, this stage is installed in the master boot record of the drive, right behind the first stage.

On a GPT drive, there isn’t enough room in the master boot record to hold that 1.5 stage, and so the GRUB installer will overwrite the raw disk blocks behind the first stage, and thus damage the partition boundary of the first data partition, and said partition’s first couple of blocks. This is why you need to create a reserved area of disk space for the 1.5 stage of GRUB, in the form of an unformatted partition of about 3 MiB in size — you can go smaller, to either 1 MiB or 2 MiB, but it’s best to be future-proof, in case the GRUB code gets bigger with future updates — and marked with the bios_grub flag. That way, the GRUB installer will recognize that partition and will write its 1.5 stage there.

Additional note: If your machine is as old as I think it is, then it may not have a whole lot of RAM, and then you should definitely also create a swap partition — you can create it on the SSD if you want.

If the machine has 4 GiB of RAM or less, then you should at least create an 8 GiB swap partition. If it has 8 GiB of RAM, then an 8 GiB swap partition is still advisable, but then you might also get away with a 4 GiB swap partition, depending on how you use the machine.

I’ve been stuck in installation. It doesnt recognize storage devices. It’s looking for it.

I have a 450s thinkpad, with 8gb ram

Maybe your installer image is corrupted. :thinking: Below are the links for the latest 21.3.7 .iso images… :arrow_down:

XFCE (full edition)

KDE Plasma (full edition)

GNOME (full edition)

If the problem is due to the switching to UEFI mode, then make sure your system is set to boot in legacy BIOS mode.

Also make sure that the CMOS battery of your firmware is still good. If the battery is no longer good, then your hardware configuration in the UEFI/BIOS will be gone, which may result in the drives not being found.


1 Like

I believe the laptop’s fine.

I just don’t know how to configure BIOS or UEFI.

Which one is better? I always used UEFI, until changing to Manjaro. Then don’t know what happens now. My both ssd and hd are still mounted and with all files in it, but in installation I’m having trouble partitioning it.

Could if it’s in UEFI, what configuration should we make in partitioning? That 3 MiB for grub should be there?

Just remembered, I haven’t made in my last Manjaro installation that 3MiB saving for grub, of course, because I didn’t knew it.

Usually it’s by pressing Del, Ins, F1 or some other function key during the hardware boot process. Commonly a message will be shown on the screen that tells you which key to press for entering the firmware setup utility.

It’s a matter of preference, really, and it also depends on whether you have multiple operating systems installed on the same machine.

  • If the machine boots in native UEFI mode, you need a GPT partition table. You do not need the bios_grub partition, but in that case you do need an EFI system partition. This EFI system partition must be between 300 to 512 MiB in size, formatted as vfat (FAT32) and marked with the esp flag.

  • If the machine boots in legacy BIOS mode, then you can have either an MBR partition table or a GPT partition table, but then in the latter case you need that 3 MiB bios_grub partition, and it must be marked with the boot flag…

This is only needed if you boot in legacy BIOS mode on a drive with a GPT partition table. It is not needed if you boot in legacy BIOS mode on a drive with an MBR partition table or if you boot in UEFI mode.

Looking a bit on Manjaro Wiki it got a little clear.

Will definetely look more about all these questions, but for now we need the computer to be installed for work, just for today, then later I’ll reinstall it again with proper configurations, which.

By now, if I install it in automatically options Calamares give me for UEFI, which’s does a FAT32 512MiB partition for /boot/uefi, would I have any troubles in the next 2-3 days?