Need to access the folder for desktop backgrounds?

I’ve got a few of my own pictures for desktop backgrounds, and I wanted to ask how I can access the system folder to put them in there? At the moment I cannot paste or copy anything into them. They are locked, obviously, but is there a way to access them?


well i’m not sure what you are describing. what about using youtube and check for “xfce customization” ? there are a lot of helpful tutorials that are pretty nice, especially if the system is new to you.

You can just make a folder in your Documents and point to it in the settings.
Don’t get me wrong, but you are still thinking in windows paradigms. And if you start messing with system folders without understanding (at all) how manjaro or linux in general functions you will break your system very soon.

But to answer the noob question: /usr/share/backgrounds is, well, in the root. Which means you have to be root or sudo to write there. That is what the “Thunar root” option in the menus does.
But if you are half way sensible: DON’T. Nothing will break from messing the background, but you will develop bad habits. Like “pointing the gun to your foot” habits.


:mag: arch change own wallpaper


:mag: manjaro change own wallpaper

P.S. Don’t use root for trivial tasks (you may regret it later) :see_no_evil:

1 Like

xfce:xfdesktop:preferences: background [Xfce Docs]

1 Like

Yep, already referenced that thanks.

Thanks. Not sure what possible damage could be caused by adding .jpgs to the existing wallpapers folder, but the warnings are noted.

1 Like
cp somefile.png /usr/share/wallpapers/

will not be allowed for a regular user.

sudo cp somefile.png /usr/share/wallpapers/

will be allowed (if you have sudo privileges and the correct password).

Do not use graphical applications as root/sudo.

1 Like

Cool, thanks…I’ll leave it as it is for the moment. I guess what I am after is just a folder to place these in so that when the desktop loads, it does so with the background previously selected. As it is on a drive that does not auto-mount (personal preference) I was trying to find a way to get them to load at boot. It’s not a big issue and certainly not big enough to risk breaking something :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.