Need some help updating the OS and Uninstalling an app

Hello Everyone!
I am new to Manjaro (installed it 2 days ago)
and I am facing 2 issues atm
1st one: is that I can’t update system (21.08.11)
through the package manager it says searching for update and then does nothing afte.
2nd one: can’t uninstall an app
need some help, I installed app called LBRY and then uninstalled it (from the store)
but it is still there somehow so if someone can help me figure out how to remove it
I tried to right-click->show details but it just open the store nothing more
I tried to remove it through the terminal sudo pacman -R lbry and got this
“error: target not found: lbry”

What error messages are shown, when pacman -Syyu on console.

no error
just this message " there is nothing to do"
tho it still shows that update available dot over the icon at the top right corner

Hi @Attia, and welcome!

Please open a terminal, run the following and provide the output here:

pamac upgrade

Also, to remove an app, in the terminal again, run:

pamac remove <applicationName>

Where <applicationName> is the name of the application you wish to remove.

Also, I recommend using pamac for managing software instead of pacman as it takes care of more things.


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

1 Like

for the first upgrade command I get this

Synchronizing package databases...
Nothing to do.
Transaction successfully finished.

but it still shows the update file if I go to the package manager

for the second command

pamac remove <applicationName>
Error: target not found: lbry

That’s probably not full app name. I don’t know which you have in mind but there is several lbry apps in AUR:

$ pamac search lbry -q

Chose which you want remove and do pamac remove <appname>

1 Like

I believe this would happen when you update with

sudu pacman -Syu

And not pamac. Because the updates notifications might be caused by AUR/Snap/Flatpac, which pamac supports, but pacman doesn’t.

it doesn’t show anything after typing the following command
it just starts the next command line

Or, if you’s rather, do:

pamac search lbry

The installed one will be marked with an [Installed] label.

Or search only in installed apps:

pamac search lbry --installed

AFAIK pending updates are applied at installation. And since there has been no update in the last two days…

What do you mean by “it is still there”?

I’d still get the same output

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

I did this and it shows nothing but just starts the next command line

and this too shows nothing but starts the next line of command
tho something that might help,
it starts automatically when I open up the laptop so is there a start up apps where I can search on or something like this?

I mean the updates are still in the package manager if I open it it shows that there are available updates
and what does pending updates mean

So you don’t have lbry installed. If @Mirdarthos command also show nothing, that mean you have also disabled AUR and/or flatpak or snap (if there also is this app).

but it is still in my apps list I swear xD

Where? I don’t believe if you don’t show us.

how to show you? xD
I can’t attach a screenshot