Need hfs+ support option for importing iPod music

I have an iPod classic that is now my only library of music, so my goal is to import all of my music and accompanying ID3 tags (tbh I’d rather not have my music than have it without tags, so this is eminently important). I’ve been following along the guide here

I know this doesn’t seem like a kernel request, and move this thread if so, but from that it looks like my classic is hfsplus formatted, and according to the guide " If you cannot see the iPod file system, it is likely that it is hfsplus formatted. For convenience, as Arch kernel is built with no support for that filesystem, you might want to restore your iPod using iTunes on Windows. This will erase all data on your iPod, and format it as a vfat filesystem"

obviously I want to avoid that. I’ve tried to mount my ipod as rw with
sudo mount -o rw /dev/sdb3 /mnt/ipd and I get no error message, but then when trying to edit the FirewireGuid: 0x[Serial_number] upon saving I get a read-only filesystem error. This is what leads me to believe it’s hfs+ formatted.

Is there a version of the Manjaro kernel that offers hfs+ filesystem support? It doesn’t seem I’ll be able to rescue the files if not, unless I’m missing someting. I can provide screenshots if needed

Make sure you installed hfsprogs from AUR
pamac build hfsprogs

Reboot the system.

First try with:
sudo mount -t hfsplus -o remount,force,rw /dev/sdb3 /mnt/ipd

Personally i prefer to first mount the partition with the File Manager, and that will mount in /run/media/myname/Label
then i run:
sudo mount -t hfsplus -o remount,force,rw /dev/sdb3 /run/media/myname/Label
I make use of alias in .bashrc so is easier …

1 Like

Finally had time to com back to this, thanks for the help. I’ve installed hfsprogs and when I run your command I get a bad option for the mount point:

sudo mount -t hfsplus -o remount,force,rw /dev/sda3 /mnt/ipd
mount: /mnt/ipd: mount point not mounted or bad option.

if is not mounted, then the command that contains the remount option will not work. I thought was clear :slight_smile:
Either you run my first command after your first command, or my second command after you mount the ipod trough file manager.

1 Like

I haven’t mounted with the file manager before is it as simple as just clicking into the ipod from the file manager window?

It should be as any external device mount, yes, but because of the way hfs+ works then once is mounted, to write into it it needs that “special” command run separately …

It worked! I can now view my iPod files from Strawberry. They don’t seem to be working on gtk and so my quest to import from my iPod isn’t finished, but this topic definitely is. Thank you!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.