Need help with screen tearing

i recently installed manjaro kde edition
and i ran minecraft and i got a lot of screen tearing
i tried capping my fps to 60 and tried vsync
if it changes anything i am using latte dock (but i disable compositor when playing)
do you know what could be causing this?

  Kernel: 5.15.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=9fb8d5c4-88d5-4f9b-9fce-eb6187af2e0e rw nouveau.modeset=0 quiet
    apparmor=1 security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: GL753VE v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: GL753VE v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: GL753VE.308 date: 04/29/2019
  ID-1: BAT0 charge: 34.3 Wh (96.1%) condition: 35.7/48.2 Wh (73.9%)
    volts: 16.1 min: 14.4 model: Simplo SDI ICR18650 type: Li-ion
    serial: <filter> status: N/A cycles: 33
  RAM: total: 15.51 GiB used: 3.13 GiB (20.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
    family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 890 high: 900 min/max: 800/3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 828 2: 900 3: 900 4: 899
    5: 900 6: 900 7: 900 8: 900 bogomips: 44817
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
    hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm
    lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
    pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: ASUSTeK
    driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:1c8c class-ID: 0302
  Device-3: Realtek USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-11:5 chip-ID: 0bda:57f6 class-ID: 0e02 serial: <filter>
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: modesetting,nvidia unloaded: nouveau,vesa alternate: fbdev,nv
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.21-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 02:00.0
    chip-ID: 8086:095a class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-9:4 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.03 TiB used: 425.86 GiB (40.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD8SN8U128G1002
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1002 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A3V0 scheme: GPT
  Optical-1: /dev/sr0 vendor: Slimtype model: DVD A DA8AESH rev: XAAM
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 114.26 GiB size: 111.9 GiB (97.94%)
    used: 24.48 GiB (21.9%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 9fb8d5c4-88d5-4f9b-9fce-eb6187af2e0e
  ID-2: /boot/efi raw-size: 508 MiB size: 507 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4 label: NO_LABEL
    uuid: 3A1A-3CFD
  ID-3: /run/media/kiing/4C5CA1685CA14E10 raw-size: 279.38 GiB
    size: 279.38 GiB (100.00%) used: 108.18 GiB (38.7%) fs: ntfs dev: /dev/sdb3
    maj-min: 8:19 label: N/A uuid: 4C5CA1685CA14E10
  ID-4: /run/media/kiing/9AF6-8E7A raw-size: 4 GiB size: 3.99 GiB (99.80%)
    used: 2.91 GiB (72.8%) fs: vfat dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 9AF6-8E7A
  ID-5: /run/media/kiing/hdd raw-size: 652.12 GiB size: 640.88 GiB (98.28%)
    used: 290.3 GiB (45.3%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: hdd
    uuid: fdcea489-5b5e-4797-9290-b68bdb95cfac
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 498 MiB fs: vfat label: N/A
    uuid: 9AF6-8E7A
  ID-2: /dev/sdb2 maj-min: 8:18 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:7 info: SINOWEALTH Wired Gaming Mouse type: Mouse,Keyboard
    driver: glorious,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 480mA
    chip-ID: 258a:0036 class-ID: 0301
  Device-2: 1-3:3 info: ASUSTek ITE Device(8910) type: Keyboard
    driver: asus,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 0b05:1854 class-ID: 0301
  Device-3: 1-9:4 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2a class-ID: e001
  Device-4: 1-11:5 info: Realtek USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:57f6 class-ID: 0e02 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 50.0 C pch: 41.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2000
  Processes: 357 Uptime: 17h 40m wakeups: 14 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.1 Packages: 1278
  pacman: 1257 lib: 337 flatpak: 13 snap: 8 Shell: Zsh v: 5.8 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.12

To start investigating, we need some more info. Here is [HowTo] Provide System Information

On KDE with Nvidia, it is recommended to enable Composition Pipeline in Nvidia Settings. Check Imgur: The magic of the Internet for reference.

is that better?

i cant change any nvidia settings (im guessing its because my laptop screen is connected to my cpu and not my gpu)

This is for normal Nvidia setup, not hybrid. I guess you could try to enable TearFree option in the xorg config then, but tha’s just a guess. Intel graphics - ArchWiki

there is no 20-intel.conf file there
only these: 00-keyboard.conf 30-touchpad.conf 90-mhwd.conf
should i just create the file or does this mean something is wrong?

You could create the file. You could also use your current xorg used file I guess too.

it didnt work
i made the file and pasted the text and rebooted but i still got screen tearing

Maybe you need to read all the article section about possible issues and other option to add, also maybe you need to NOT disable the compositor.

What is the content of the file you created?
What did you set in game, did you try with and without the Vsync option?
How do you run the game?

i disable compositor since i use latte-dock with blurring so it takes a lot of cpu when playing games

  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"

am i supposed to change the identifier and driver?
2 i tried vsync, capping my fps at 60, and setting it to unlimited
3. i use multi mc with the “prime-run” command so it uses my gpu

If this is the content of the file, you’re missing a part, make sure you did it properly.

Maybe try without disabling the compositor.

Also maybe try to add the triple buffer option as mentioned in the section of the article I linked.

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
  Option "TripleBuffer" "true"

I don’t have an hybrid setup so I can’t guarantee what to do.