Need help with permission issues

First off, I’m a noob with all this linux thing so please bear with me!

A few months ago I partitioned my 500GB HDD and installed Manjaro on the smaller partition, being Windows 10 on the largest using dual boot. I also have another HDD of 2TB where I store my personal files, etc.
However when using Manjaro I can copy files frome those drives but not paste or create files on them. So far I’ve tried chaning the ownership of the drives to root, and current user, no avail.

Any help would be appreciated!

Welcome to the forum! :beer:

Now, the first thing you need to know, is that GNU/Linux is a UNIX-style operating system, and in UNIX/POSIX, the file ownership and permissions are stored in the filesystem itself.

However, filesystems such as FAT-derivatives and NTFS do not support POSIX file ownership and permissions. This means that such permissions and ownership must be faked in the kernel’s virtual filesystem layer while the “alien” filesystem is mounted, and that they will not be preserved when the filesystem is unmounted again ─ e.g. when the system reboots.

The best way of going about this is to look into adding a record ─ i.e. a line, with space-separated fields ─ for each of those filesystems to /etc/fstab. You can then specify a default permissions mask that the kernel will fake for the entire “alien” filesystem, and a default ownership.

  • See this link for the manual on /etc/fstab.
  • See this link for the available mount options per filesystem type.

You can edit /etc/fstab by way of nano. Open up a terminal window and issue the following command…

sudo nano /etc/fstab

You will be prompted for your password. You can then edit the file, and when you’re done, press Ctrl+O to save the file. You will be prompted for a filename, but if you just press Enter, it’ll overwrite the file. Then you exit the editor again with Ctrl+X.

Hope this helps. :wink:

Thank you for your response. I’ll look into it and we’ll see how it goes!

1 Like

Given that you’re essentially on a single-user setup, I would recommend creating the two needed mountpoints as empty folders under your $HOME, e.g. /home/aberwag/data/win_c and /home/aberwag/data/win_d.

That way you can more easily navigate to those two partitions from within your file manager (or by way of a terminal), and then the permissions on the folders themselves will already be correct ─ it’s an avoided extra hurdle compared to if you were to create mountpoints in the root directory, which would then by default be root-owned. :wink:

P.S.: You must also make sure that the Windows Fast Boot option is disabled, or else GNU/Linux will always mount your Windows filesystems as read-only.

1 Like
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

That was the console’s output when I tried to mount the 2TB drive and, as suspected, it got mounted as read-only.

Is there any way to disable Windows fast boot from linux? The main reasong I’m doing this is because I want to transfer files from :C/ to that 2TB drive because Windows boot got corrupted and I can’t do anything with it!

I’m afraid not. I’m not even familiar with the feature ─ I don’t use Microsoft Windows ─ and so it was my impression that this must be disabled either in Windows itself or in the UEFI firmware configuration screen.

1 Like

Oh well, thanks for your help!

You’re in a right pickle then, I’m afraid! Unfortunately, fast boot (in other words, core windows bits hibernation) makes it so that everything is written to disk and synced when the system is shut-down (i.e. ‘Metadata kept in Windows cache’ ), hence the ‘unclean file system’ warning. And because it’s a Windows setting, it can only be done in Windows, not from UEFI/BIOS - fast boot there is only related to the Power On Self Test (POST) checks. And even more unfortunate, you would need to get the system to resume from that hibernation point to get the drive into the state it should be.

However, if your Windows install is broken already, you’re only really option will be to access it read only, and copy off the files you need to recover, and then reformat it. You could probably force it to be mounted read-write, but I wouldn’t trust the integrity of the data on the drive if it were in that state. You would probably be better off attempting to recover the windows install (via startup repair or an in-place upgrade install) and then getting it to check the file-system integrity itself, and then going on from there.

Or removing Windows for good, and sticking with Manjaro! :wink: :laughing:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.