Need help with japanese IME


I would like to start typing in japanese, I’ve tried different methods, but there seems to be nothing satisfactory.

I do not get why I would need to change my typing method. All of the tutorials I’ve seen recommend using ibus, uim or something else. I am currently using xmodmap because I have a custom keyboard layout. It works perfectly fine and I do not want to change it. I have tried ibus, but it broke my custom layout for typing english and french. Is there no software that simply turns what I type in latin characters into japanese kana ? Then the IME would just need to suggest the kanji to use.

I’m using KDE as my desktop environment, and the stable release of Manjaro.

Thanks if anyone’s able to help

Try Fcitx

I’ve tried it too. When trying to change the layout, it simply refuses to work, be it using the hotkey or the menu accessed using the toolbar icon. Nothing happens, and I just end up typing the usual latin characters.

Did you install plugins? For QT apps you need fcitx5-qt, for GTK apps it’s fcitx5-gtk etc.

I tried fcitx5, as I had tried fcitx previously. I’ve installed the fcitx-5qt and fcitx5-gtk packages too, but it just doesn’t work with any apps. It only worked with the “test input” in the config menus. Now that I’ve rebooted, it doesn’t even want to switch from my normal input to mozc anymore, as it used to do.

Ended up finding a solution. If anyone is looking for a fix, I added


to /ect/environment

If you want to keep your current layout for writing japanese, change the input mode in mozc’s settings to romaji.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.