Need help setting up eGPU NVIDIA environment

Hello community,

What I want to do:
I am trying to set an eGPU environment with a NVIDIA GTX 1070 card.

My Setup:

  • Dell XPS 15 (9570) 2018 with Intel i7 8th generation
  • 16 GB RAM
  • internal Intel graphic chip
  • internal NVIDIA GTX 1050 TI
  • Thunderbold 3 port
  • eGPU Case with a NVIDIA 1070, many USB Ports and GBit Ethernet on it


  • Kernel: 6.1.49-1-MANJARO
  • 64 Bit
  • GNOME 44.4
  • Window manager: X11

What I’ve already done:

  • Set up a blank new installation several times and install all updates with pamac upgrade
  • Installed proprietary NVIDIA drivers
  • After allowing Thunderbold to connect, my USB ports and Ethernet port are working well on the eGPU case.
  • In one case, the eGPU Screen turned on and the eGPU seems to work. The system became VERY! laggy. After a reboot the eGPU stopped to work.
  • In another case, I got the internal GTX 1050 working. After a reboot, yes, you’ve got it… It stopped working. I am not able to reproduce on of these cases.
  • I tried several “How to” guides and tools.
  • I tried the eGPU switcher: GitHub - hertg/egpu-switcher: 🖥🐧 Setup script for eGPUs in Linux (X.Org)

Three graphic devices are identified:

Two of them are my NVIDIA cards:

Do I have to configure something here?

The settings manager looks like that the moment:

Are there any misconfigurations?

Everything looks good in my eyes.

I have an update.
I could reproduce the state, that the eGPU seems to work after a fresh reinstall.
The Thunderbold cable must be plugged in during the install process. After the reboot, you have to legitimate the tunderbold connection.

What are my findings?

  • It seems to be very important, that you select the “open source drivers” during the install process .
  • The window manager is wayland

The screen, connected to the eGPU, turned on after I legitimated the thunderbold connection. It worked without installing updates and worked after installing all updates.

I will make some performance tests in the next days.

How can I make sure that the eGPU is really working?

NOTE: If you ever switch to the properitarian driver in the majaro settings manager, the eGPU function will break. I tested it so you don’t have to. I tried several settings, but I can’t bring it back to life.

Okay… I gave up :frowning: