Need help reinstalling Grub on encrypted Btrfs disk

I migrated my system from a different nvme to a new one.
And I upgraded my BIOS.
Now when booting, I get:

error: symbol 'grub_is_shim_lock_enabled' not found.

From what I understand I need to reinstall Grub to get it to successfully boot.

In BIOS I disabled Fast Boot (Not MRC Fast Boot)

  • disabled TPM
  • disabled CPM
  • disabled secure boot (and set one secure boot setting to custom)
    on my ASUS mainboard.

In Grub menu, I “detected” the following efi boot loaders:

I once used manjaro-chroot but I don’t think it works with btrfs and its auto-snapshot system that I enabled.

can I go by this tutorial on Fix grub on btrfs partition | :

# mount the btrfs root subvolume
mount /dev/sda1 /mnt -o subvol=/
# (optional) set the default subvolume
btrfs sub set @ /mnt
mount /proc /mnt/proc --bind
mount /dev /mnt/dev --bind
mount /sys /mnt/sys --bind
chroot /mnt
grub-install /dev/sda
update-grub /dev/sda
# activate first partition
fdisk -l /dev/sda


Have you read the wiki, myself…
I just discovered with Manjaro Wiki :slight_smile:

It was updated too :slight_smile:

Solved, if anyone wants I can post the exact commands I ran.
If this thread is considered too much, or unnecessary, please feel free to delete it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.