Need help reconfiguring the terminal

I did a reinstall of Manjaro a few days ago. I have a separate partition for the home folder so I only reinstalled the system and then configured the separate partition as my home folder again. This went smoothly for almost everything except the terminal.

I used to have something like [username@machine ~] and several colors and the terminal would indicate in which folder I was.

Now it’s just this:

I’ve followed the steps in this topic, but this has not solved the problem. By why of troubleshooting I’ve also deleted my .config folder just to check. But that also didn’t solve the problem. I’ve made a separate test user, in which de default manjaro configs are present.

Any ideas on how to get fuller terminal?

What steps? That user had a different issue.

Please define.

First I did:

install manjaro-zsh-config and paste this in your ~/.zshrc:

# Use powerline
# Source manjaro-zsh-configuration
if [[ -e /usr/share/zsh/manjaro-zsh-config ]]; then
  source /usr/share/zsh/manjaro-zsh-config
# Use manjaro zsh prompt
if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then
  source /usr/share/zsh/manjaro-zsh-prompt

and then:

source ~/.zshrc

And I also did:

default setting is in /etc/skel
copy that to your HOME and you should have restored what Manjaro came with
if you have

Please define.

I mean that currently I can’t see which directory I’m in. I can’t use the delete button because I get ~. I don’t see any colours indicating differences in text. In short: a lot of basics are not present.

Omg this was some weird rubberducking. In copying I noticed that I didn’t do this. And now I did. And defaults of manjaro are restored.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.