Need help installing TP-LINK TL WN8200ND Ver:3.0

Hello, I just go this wifi adapter TL WN8200ND Ver:3.0 but it doesn’t work on linux.

as suggested in: TP-Link TL-WN8200ND(UN) ver 2.20, USB is not recognized and set up on Manjaro 21 KDE iso - #2 by bogdancovaciu

I tried to install: GitHub - luckynzm/tlwn8200nddriver: Linux driver for TP-Link WN8200NDV2 it’s for V2 but I’ll just hope it will work for V3.

But I think I need assistance.

    ~/Applications  git clone                                                                                         128 ✘  10s  
Cloning into 'tlwn8200nddriver'...
remote: Enumerating objects: 479, done.
remote: Total 479 (delta 0), reused 0 (delta 0), pack-reused 479
Receiving objects: 100% (479/479), 2.10 MiB | 1.71 MiB/s, done.
Resolving deltas: 100% (157/157), done.
    ~/Applications  cd tlwn8200nddriver                                                                                                                                            ✔ 
    ~/Applications/tlwn8200nddriver    master    sudo dkms add .                                                                                                                ✔ 
Deprecated feature: REMAKE_INITRD (/home/unary/Applications/tlwn8200nddriver/dkms.conf)
Deprecated feature: REMAKE_INITRD (/usr/src/rtl8192eu-1.0/dkms.conf)
Creating symlink /var/lib/dkms/rtl8192eu/1.0/source -> /usr/src/rtl8192eu-1.0
    ~/Applications/tlwn8200nddriver    master    sudo dkms install rtl8192eu/1.0                                                                                                ✔ 
Error! Your kernel headers for kernel 6.1.38-1-MANJARO cannot be found at /usr/lib/modules/6.1.38-1-MANJARO/build or /usr/lib/modules/6.1.38-1-MANJARO/source.
Please install the linux-headers-6.1.38-1-MANJARO package or use the --kernelsourcedir option to tell DKMS where it's located.

I’m stuck at this step.
How do I install linux-headers-6.1.38-1-MANJARO?

sudo dkms install rtl8192eu/1.0                                                                                                ✔ 
[sudo] password for unary: 
Sign command: /usr/lib/modules/6.1.38-1-MANJARO/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/
Deprecated feature: REMAKE_INITRD (/var/lib/dkms/rtl8192eu/1.0/source/dkms.conf)

Building module:
Cleaning build area...
'make' all KVER=6.1.38-1-MANJARO...(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.38-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtl8192eu/1.0/build/make.log for more information.

I’m stuck at this stage

content of the log file:

DKMS make.log for rtl8192eu-1.0 for kernel 6.1.38-1-MANJARO (x86_64)
Thu Jul 13 11:21:28 WIB 2023
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/6.1.38-1-MANJARO/build M=/var/lib/dkms/rtl8192eu/1.0/build  modules
  CC [M]  /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o
In file included from /var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h:45,
                 from /var/lib/dkms/rtl8192eu/1.0/build/include/drv_types.h:32,
                 from /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.c:22:
/var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.c: In function ‘rtw_cmd_thread’:
/var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service_linux.h:165:31: error: implicit declaration of function ‘complete_and_exit’ [-Werror=implicit-function-declaration]
  165 |         #define thread_exit() complete_and_exit(NULL, 0)
      |                               ^~~~~~~~~~~~~~~~~
/var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.c:759:9: note: in expansion of macro ‘thread_exit’
  759 |         thread_exit();
      |         ^~~~~~~~~~~
/var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.c:761:1: error: control reaches end of non-void function [-Werror=return-type]
  761 | }
      | ^
cc1: some warnings being treated as errors
make[2]: *** [scripts/ /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o] Error 1
make[1]: *** [Makefile:2012: /var/lib/dkms/rtl8192eu/1.0/build] Error 2
make: *** [Makefile:1700: modules] Error 2

I just installed AUR (en) - rtl8192eu-git. it kinda works now.
But it looked like it doesn’t perform as good as it was in windows.

It’s not ideal solution. It only reaches 2mbps download and 0.5 mbps upload. While it can reach 40mbps on Windows.

I think I still need assistance on this matter.

Oh oh, this one works beautifully:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.