Need Help Identifying Bluetooth Gamepad Input Device in Manjaro

Hello Manjaro community,

I hope this message finds you well. I’m currently facing a problem identifying the input device file associated with my Bluetooth gamepad under Manjaro, and I’m asking the community for help.

Here’s a brief overview of the problem:

I have a Bluetooth gamepad that I have successfully connected to my Manjaro system. However, I’m having trouble determining which file in /dev/input/ corresponds to the gamepad input. I checked the directory with the ls command /dev/input/ and noticed several files, but I’m not sure which one is associated with my gamepad.

I’ve tried connecting and disconnecting the gamepad to see if any files appear or disappear, but I’m still not sure which file is correct. Also, I’ve used the ls -l /dev/input/ command to get more details about the files, but I’d appreciate advice on how to accurately identify the Bluetooth gamepad’s input device.

If anyone has experience with Bluetooth gamepads on Manjaro or can offer advice on determining the correct input file, I would be extremely grateful for your help.

In addition, I’d like to mention that connecting my device via Bluetooth is quite complicated, requiring several attempts before it works properly. I’ve created a little script so that it automatically tries to reconnect, as it often fails on the first few attempts. Here’s an example script:

while ! bluetoothctl info "$device" | grep -q "Connected: yes"; do
    bluetoothctl connect "$device"
    sleep 1

I’ve also tried connecting my gamepad directly to USB-C, but the same problem occurs - I get no input. I tried to install xpadneo-dkms-git as indicated on Arch’s wiki, but without success.

Thanks in advance for your time and support!

Best regards,