Need help getting my dual graphics running (Intel/nvidia)

You are running nvidia prime according to your screen shots. By default manjaro uses the intergrated graphics, to use the nvidia card then you need to launch applications with the prime-run command. The easiest way for gaming is to use lutris and then enable the prime render offload option, this will launch games on the nvidia card

1 Like

Hi, thanks for your reply. I enabled Prime Render Offload Option in Lutris, started Minecraft and used glxinfo | grep “OpenGL renderer” to show the active GPU:

OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)

Btw, sudo nvidia-settings opens the GUI but I get this in Terminal:

(nvidia-settings:8239): GLib-GObject-CRITICAL **: 21:39:47.601: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with
       this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application
       profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed
       in the help text. Please see the README for possible values and descriptions.

If you are using PRIME … then this is for intel:
glxinfo | grep "OpenGL renderer"
and this is for the nvidia (notice prime-run):
prime-run glxinfo | grep "OpenGL renderer"

Please see:
https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

[edited to fix syntax]

1 Like

Thanks for your reply!

Running the command for nvidia results in:

grep: renderer”: No such file or directory

Will read that guide you linked. Thanks!

Sorry. I just copied what you had used, assuming it was functional (bad form :laughing:)

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

PS - I see now why … notice the difference between " and … using the first form would have worked.

I see!

$ glxinfo | grep 'renderer string'
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)

$ prime-run glxinfo | grep 'renderer string'
OpenGL renderer string: GeForce GTX 1650/PCIe/SSE2

But how do I know which card is used/active when playing a game for instance? I’m confused. xD

You launch the game with prime-run

For example in Steam has ‘launch options’ … so dont start steam itself with prime-run, rather you go to game launch options and put (assuming no other options):

prime-run %command%

If it were something simpler I would just launch it with prime-run from terminal, or copy/edit the .desktop file, etc.

1 Like

Got it, thanks a lot!

So can I just keep video-linux and video-vesa?

And what about updating drivers? I’m still running video-hybrid-intel-nvidia-450x-prime. Can I just install 550xx using the GUI (hardware configuration) and delete the old one or do I have to consider anything?

You can use manjaro settings manager to uninstall the 450 prime drivers and then install the 455 prime driver yes

You shouldnt have either of those … especially vesa.
(I guess it would probably be fine to have ‘video-linux’ then install the prime profile on top…)

And your output seems to show you dont have them installed.


They will be updated along with all the other packages.
If you mean a different series or mhwd profile … then if it is available/compatible then it will be present as an option there (or the GUI frontend - ‘manjaro-settings-manager’)… such as 450xx.

1 Like

Oops, my bad. Misinterpreted the GUI. Tried to upload a screenshot but (I guess since I’m a new user) I’m not allowed to. Latest driver showing is video-hybrid-intel-nvidia-455x-prime.

I think 455 has some minor issues, so 450 might be preferred for the moment.
(actual nvidia users probably know better :wink:)

This is really helpful information.

Thanks!

Tried that using the GUI. When trying to install 450xx I get:

Starting

Error: config 'video-hybrid-intel-nvidia-450xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-440xx-prime

Trying to uninstall 440xx leads to:

Starting

> Removing video-hybrid-intel-nvidia-440xx-prime...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-440xx-prime/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

checking dependencies...

error: failed to prepare transaction (could not satisfy dependencies)

:: removing linux58-nvidia-440xx breaks dependency 'linux58-nvidia-440xx' required by linux-latest-nvidia-440xx

Error: pacman failed!

Error: script failed!

Thanks for helping! For some reason I can’t get this done.

$ sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

Error: config 'video-hybrid-intel-nvidia-450xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-440xx-prime

I don’t seem to have linux-latest-nvidia-440xx:

$ sudo pacman -R linux-latest-nvidia-440xx

Error: not found: linux-latest-nvidia-440xx

Do I just need to go for $ sudo pacman -R video-hybrid-intel-nvidia-440xx-prime instead?

In Pamac the following are displayed as installed:

nvidia-440xx-utils
lib32-nvidia-440xx-utils
linux54-nvidia-440xx
linux57-nvidia-440xx
linux58-nvidia-440xx
mhwd-nvidia-440xx

Can you not do it with the manjaro settings gui? You should be able to uninstall any nvidia drivers from there and then install the ones you want

Ok, that worked. -_-

I swear I’d always get an error trying it via settings manager. Just did so to copy the error message and it worked. Uninstalled video-hybrid-intel-nvidia-440xx-prime and installed 550xx after, then rebooted.

Thanks!

If I remember correctly there was a bug in manjaro settings gui a month or so ago but it got fixed so your probably not going mad

Edit:

Did it get fixed recently? It was four days ago when I tried it the last time. Error message in post #15 in this topic.

Anyways, it’s working now. Thanks a lot!

1 Like