Need help getting my dual graphics running (Intel/nvidia)


since installing Manjaro a few month ago I’m not able to get my Nvidia card running. Reading the post of another user having similar issues, I think I could have messed up my settings from the very beginning. Solution for his/her problem was uninstalling video-linux and video-vesa. Trying that using mhwd -r results in Error: invalid use of option: -r/–remove

I’m pretty new to Linux/Manjaro and don’t know what’s the best way to solve this for me. I’d be very happy if someone on here could help me.

Here’s my inxi -Fazy:

  Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=195ea558-b5d4-4789-b440-595bf058771d rw quiet apparmor=1 
  security=apparmor resume=UUID=7f391a74-a843-4390-98a5-36e7b1d6322f 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0VYV0G v: A00 serial: <filter> UEFI: Dell v: 1.7.0 
  date: 05/11/2020 
  ID-1: BAT0 charge: 84.5 Wh condition: 84.5/97.0 Wh (87%) volts: 13.0/11.4 
  model: SMP DELL GPM0365 type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62431 
  Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 802 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] 
  vendor: Hewlett-Packard driver: nvidia v: 440.100 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f91 
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-12:5 chip ID: 0c45:6723 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") 
  s-diag: 581mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  Monitor-2: DP-1 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") 
  diag: 686mm (27") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
  Device-1: Intel Wi-Fi 6 AX200 vendor: Bigfoot Networks driver: iwlwifi 
  v: kernel port: 3000 bus ID: 3b:00.0 chip ID: 8086:2723 
  IF: wlp59s0 state: up mac: <filter> 
  Local Storage: total: 476.94 GiB used: 228.83 GiB (48.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG60ZNV512G NVMe 512GB 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 10604106 scheme: GPT 
  ID-1: / raw size: 459.85 GiB size: 451.64 GiB (98.21%) 
  used: 228.83 GiB (50.7%) fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.79 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 286 Uptime: 12m Memory: 15.26 GiB used: 1.44 GiB (9.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1358 lib: 393 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

And my mhwd -li:

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-440xx-prime            2020.10.04               false            PCI

Warning: No installed USB configs!

Thanks a lot and have a great weekend!

You are running nvidia prime according to your screen shots. By default manjaro uses the intergrated graphics, to use the nvidia card then you need to launch applications with the prime-run command. The easiest way for gaming is to use lutris and then enable the prime render offload option, this will launch games on the nvidia card

1 Like

Hi, thanks for your reply. I enabled Prime Render Offload Option in Lutris, started Minecraft and used glxinfo | grep “OpenGL renderer” to show the active GPU:

OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)

Btw, sudo nvidia-settings opens the GUI but I get this in Terminal:

(nvidia-settings:8239): GLib-GObject-CRITICAL **: 21:39:47.601: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with
       this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application
       profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed
       in the help text. Please see the README for possible values and descriptions.

If you are using PRIME … then this is for intel:
glxinfo | grep "OpenGL renderer"
and this is for the nvidia (notice prime-run):
prime-run glxinfo | grep "OpenGL renderer"

Please see:

[edited to fix syntax]

1 Like

Thanks for your reply!

Running the command for nvidia results in:

grep: renderer”: No such file or directory

Will read that guide you linked. Thanks!

Sorry. I just copied what you had used, assuming it was functional (bad form :laughing:)

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

PS - I see now why … notice the difference between " and … using the first form would have worked.

I see!

$ glxinfo | grep 'renderer string'
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)

$ prime-run glxinfo | grep 'renderer string'
OpenGL renderer string: GeForce GTX 1650/PCIe/SSE2

But how do I know which card is used/active when playing a game for instance? I’m confused. xD

You launch the game with prime-run

For example in Steam has ‘launch options’ … so dont start steam itself with prime-run, rather you go to game launch options and put (assuming no other options):

prime-run %command%

If it were something simpler I would just launch it with prime-run from terminal, or copy/edit the .desktop file, etc.

1 Like

Got it, thanks a lot!

So can I just keep video-linux and video-vesa?

And what about updating drivers? I’m still running video-hybrid-intel-nvidia-450x-prime. Can I just install 550xx using the GUI (hardware configuration) and delete the old one or do I have to consider anything?

You can use manjaro settings manager to uninstall the 450 prime drivers and then install the 455 prime driver yes

You shouldnt have either of those … especially vesa.
(I guess it would probably be fine to have ‘video-linux’ then install the prime profile on top…)

And your output seems to show you dont have them installed.

They will be updated along with all the other packages.
If you mean a different series or mhwd profile … then if it is available/compatible then it will be present as an option there (or the GUI frontend - ‘manjaro-settings-manager’)… such as 450xx.

1 Like

Oops, my bad. Misinterpreted the GUI. Tried to upload a screenshot but (I guess since I’m a new user) I’m not allowed to. Latest driver showing is video-hybrid-intel-nvidia-455x-prime.

I think 455 has some minor issues, so 450 might be preferred for the moment.
(actual nvidia users probably know better :wink:)

This is really helpful information.


Tried that using the GUI. When trying to install 450xx I get:


Error: config 'video-hybrid-intel-nvidia-450xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-440xx-prime

Trying to uninstall 440xx leads to:


> Removing video-hybrid-intel-nvidia-440xx-prime...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-440xx-prime/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

checking dependencies...

error: failed to prepare transaction (could not satisfy dependencies)

:: removing linux58-nvidia-440xx breaks dependency 'linux58-nvidia-440xx' required by linux-latest-nvidia-440xx

Error: pacman failed!

Error: script failed!

Thanks for helping! For some reason I can’t get this done.

$ sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

Error: config 'video-hybrid-intel-nvidia-450xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-440xx-prime

I don’t seem to have linux-latest-nvidia-440xx:

$ sudo pacman -R linux-latest-nvidia-440xx

Error: not found: linux-latest-nvidia-440xx

Do I just need to go for $ sudo pacman -R video-hybrid-intel-nvidia-440xx-prime instead?

In Pamac the following are displayed as installed:


Can you not do it with the manjaro settings gui? You should be able to uninstall any nvidia drivers from there and then install the ones you want

Ok, that worked. -_-

I swear I’d always get an error trying it via settings manager. Just did so to copy the error message and it worked. Uninstalled video-hybrid-intel-nvidia-440xx-prime and installed 550xx after, then rebooted.


If I remember correctly there was a bug in manjaro settings gui a month or so ago but it got fixed so your probably not going mad