Nautilus does not show syncing services

Nautilus does not show syncing services (google, nextcloud) in the sidebar even though I’ve logged in and activated syncing in gnome-settings → online accounts.

I’m not quite sure how and when that happen, it used to work before. I’ve tried to log out and log back in but the issue still persists. I’m sure the issue is somehow related to nautilus as other apps like calendar and contacts sync without any issues.

This issue is related but as you can see it has not been solved for five years.

System info
$ inxi -v7azy
  Kernel: 5.18.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=b1fc74e5-d9ba-4f03-a7d7-c543e7b8b686 rw audit=0 quiet splash
    apparmor=1 security=apparmor udev.log_priority=3
  Desktop: GNOME v: 42.2 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HUAWEI product: MACH-WX9 v: M12
    serial: <superuser required>
  Mobo: HUAWEI model: MACH-WX9 v: M12 serial: <superuser required>
    UEFI: HUAWEI v: 1.28 date: 03/15/2019
  ID-1: BAT0 charge: 28.1 Wh (83.1%) condition: 33.8/56.3 Wh (60.0%)
    volts: 8.1 min: 7.6 model: DYNAPACK HB4593R1ECW type: Li-ion
    serial: <filter> status: charging cycles: 12
  RAM: total: 15.38 GiB used: 4.13 GiB (26.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 built: 2017 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3947 high: 4002 min/max: 400/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3887 2: 3853 3: 4001
    4: 3894 5: 4000 6: 4000 7: 3940 8: 4002 bogomips: 32012
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep sgx
    smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Huawei driver: i915 v: kernel
    arch: Gen9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917
    class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Huawei driver: nvidia
    v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Maxwell process: TSMC 28nm
    built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d12 class-ID: 0302
  Device-3: Cheng Uei Precision Industry (Foxlink) HD Camera type: USB
    driver: uvcvideo bus-ID: 1-7:3 chip-ID: 05c8:03c0 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model-id: JDI 0x422a built: 2017 res: 3000x2000 dpi: 260
    gamma: 1.2 size: 293x196mm (11.54x7.72") diag: 353mm (13.9") ratio: 3:2
    modes: 3000x2000
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 22.1.1
    direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Huawei
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.5-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Wireless 8265 / 8275 vendor: Huawei driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0
    chip-ID: 8086:24fd class-ID: 0280
  IF: wlp60s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-5:2 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 195.83 GiB (41.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: AAXA4103 temp: 41.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 232.64 GiB size: 227.93 GiB (97.97%)
    used: 195.79 GiB (85.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: b1fc74e5-d9ba-4f03-a7d7-c543e7b8b686
  ID-2: /boot/efi raw-size: 300 MiB size: 98.4 MiB (32.82%)
    used: 39.8 MiB (40.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: N/A uuid: D547-F07B
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4 GiB used: 280 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p6 maj-min: 259:6 label: swap
    uuid: 800e57d7-ef68-4a56-bcf1-e153ccfab98e
  ID-1: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: ext4 label: N/A
    uuid: 9ea901f4-edaa-4de0-b311-506906d90038
  ID-2: /dev/nvme0n1p4 maj-min: 259:4 size: 123.57 GiB fs: ntfs label: N/A
    uuid: 2C96186096182CB8
  ID-3: /dev/nvme0n1p5 maj-min: 259:5 size: 116.42 GiB fs: ext4 label: N/A
    uuid: 9ea901f4-edaa-4de0-b311-506906d90038
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2b class-ID: e001
  Device-2: 1-7:3 info: Cheng Uei Precision Industry (Foxlink) HD Camera
    type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 05c8:03c0 class-ID: 0e02
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 63.0 C pch: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 287 Uptime: 19h 10m wakeups: 30 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: 1286 pacman: 1204 lib: 297 flatpak: 82 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.19
$ nautilus .
** (org.gnome.Nautilus:41730): WARNING **: 14:18:15.153: Unable to initialize tag manager: SQL logic error
Relevant packages
$ pacman -Q | grep "nautilus\|gnome"
gnome-autoar 0.4.3-2
gnome-bluetooth-3.0 42.1-1
gnome-calculator 42.1-1
gnome-calendar 42.1-1
gnome-characters 42.0-1
gnome-clocks 42.0-1
gnome-color-manager 3.36.0+r25+g4aab8b59-1
gnome-contacts 42.0-1
gnome-control-center 42.2-1
gnome-desktop 1:42.2-1
gnome-desktop-4 1:42.2-1
gnome-desktop-common 1:42.2-1
gnome-disk-utility 42.0-1
gnome-firmware 42.2-1
gnome-font-viewer 42.0-1
gnome-keyring 1:42.1-1
gnome-logs 42.0-1
gnome-menus 3.36.0-1
gnome-online-accounts 3.44.0-1
gnome-screenshot 41.0+r25+g45f08f0-1
gnome-session 42.0-1
gnome-settings-daemon 42.2-1
gnome-shell 1:42.2-1
gnome-shell-extension-pop-shell 1.2.0+268+g811201b-1
gnome-software 42.2-1
gnome-system-monitor 42.0-1
gnome-terminal-transparency 3.44.1-1
gnome-themes-extra 3.28+r6+g45b1d457-1
gnome-tweaks 42beta+r9+gc66d8c3-1
gnome-user-share 3.34.0-2
gnome-wallpapers 20201020-1
gnome-weather 42.0-1
libgnomekbd 1:3.26.1+r5+g54da436-1
libnautilus-extension 42.2-1
lighter-gnome 20211216-1
manjaro-gnome-settings 20220606-1
nautilus 42.2-1
nautilus-admin 1.1.9+5+ga51885e-1
nautilus-empty-file 1.2-2
polkit-gnome 0.105-9
python-nautilus 1.2.3-7
qgnomeplatform-qt5 0.8.4-3
qgnomeplatform-qt6 0.8.4-3
xdg-desktop-portal-gnome 42.1-1

After doing some thinking I could have just run pacman -Si gnome-online-accounts nautilus and looked for optional dependencies :person_facepalming:. And installed packages @Yochanan mentioned.

Make sure you have gvfs-goa and gvfs-google installed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.