Mysterious behaviour of Google Chrome and Spotify

Good evening - I have worked my way through the search, but unfortunately did not find what I was looking for. Hence my unloved question here at this point. (Yes, I know, you should use Chromium and not the Google plague.) Unfortunately, an important app for speech recognition - which is very important for me - only works in the “original Google derivative” - so I use it.

Now to the actual problem:

System: Mate - current distribution - Manjaro (Same behaviour also under Gnome).

When I auto login, Spotify or Chrome asks me for my password to unlock a keychain. The next time I log in automatically, this happens again and it’s annoying.

If, on the other hand, I don’t let myself log in automatically, it doesn’t happen that I’m asked for a password to unlock.

I know the solution of deleting the password in the keyring manager and leaving it blank - but this doesn’t help for long, it resets itself by magic at some point.

My nerves would really appreciate a helpful tip!
Thank you!

Solution: Disable logging in automatically as the keyring does not get unlocked. The same thing applies to logging in with a fingerprint reader for some reason.

1 Like

But that doesn’t sound like a solution, it sounds like a desperate way around the problem.

Nevertheless, thank you very much for your approach.

PS: I think I have found a solution in the last hour, but I have to try it first before I give hope to many annoyed and desperate people here.

You can also set empty password for keyring. But this is not recommended and mean your secrets will be unencrypted.

automatic login = no automatic keyring unlock.
You could have ~something~ prompt you to unlock the keyring after autologin though.
Either way … you will have to be prompted at some point to decrypt them somehow.


Let’s have a look - actually 5th reboot without secrets under spotify and chrome ^^ 10 times more and I build up a firework for my own. After more then 5 years killing my nerves with that stupid bug.