My wifi automatically softblocks itself

Hi, this has been a problem with me for quite sometime, out of nowhere my wifi suddenly softblocks itself, it is not due to power management I assume because my battery was at 40% and it automatically softblocked. I do not have my user in the rfkill group and I have no idea what causes it. Can someone please provide me some guidance, I’ll provide any output as desired

here is my journal output journal pastebin

also here is the output of systemctl list-unit-files --state=enabled

UNIT FILE                                                   STATE   VENDOR PRESET
var-lib-snapd-snap-code-72.mount                            enabled disabled     
var-lib-snapd-snap-code-73.mount                            enabled disabled     
var-lib-snapd-snap-core-11420.mount                         enabled disabled     
var-lib-snapd-snap-core-11606.mount                         enabled disabled     
var-lib-snapd-snap-core18-2074.mount                        enabled disabled     
var-lib-snapd-snap-core18-2128.mount                        enabled disabled     
var-lib-snapd-snap-core20-1081.mount                        enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-161.mount       enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d38\x2d2004-39.mount        enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d38\x2d2004-70.mount        enabled disabled     
var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1515.mount       enabled disabled     
var-lib-snapd-snap-postman-145.mount                        enabled disabled     
var-lib-snapd-snap-postman-147.mount                        enabled disabled     
var-lib-snapd-snap-teams-5.mount                            enabled disabled     
var-lib-snapd-snap-wine\x2dplatform\x2d5\x2dstable-16.mount enabled disabled     
var-lib-snapd-snap-wine\x2dplatform\x2druntime-240.mount    enabled disabled     
var-lib-snapd-snap-wine\x2dplatform\x2druntime-241.mount    enabled disabled     
cups.path                                                   enabled disabled     
apparmor.service                                            enabled disabled     
avahi-daemon.service                                        enabled disabled     
bluetooth.service                                           enabled disabled     
cronie.service                                              enabled disabled     
cups.service                                                enabled disabled     
getty@.service                                              enabled enabled      
haveged.service                                             enabled disabled     
lightdm-plymouth.service                                    enabled disabled     
linux-module-cleanup.service                                enabled disabled     
ModemManager.service                                        enabled disabled     
NetworkManager-dispatcher.service                           enabled disabled     
NetworkManager-wait-online.service                          enabled disabled     
NetworkManager.service                                      enabled disabled     
snapd.apparmor.service                                      enabled disabled     
snapd.service                                               enabled disabled     
systemd-timesyncd.service                                   enabled enabled      
tlp.service                                                 enabled disabled     
ufw.service                                                 enabled disabled     
avahi-daemon.socket                                         enabled disabled     
cups.socket                                                 enabled disabled     
remote-fs.target                                            enabled enabled      
pamac-cleancache.timer                                      enabled disabled     
pamac-mirrorlist.timer                                      enabled disabled     

41 unit files listed.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. That’s 3 days of logs. Can’t you pinpoint it a bit more precisely? :sweat:

  4. Have you turned off power management for the adapter? If yes, how?

:+1:

P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.

Thank you fabby apologies for the long journal output, I’m a complete noob
I was able to solve the problem by blacklisting ideapad_laptop kernel module
Thanks again!

2 Likes

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.