My usb stick isn't recognized

I am trying to use an usb stick that I recently formatted and it doesn’t show up in the file manager and I can’t open it.I tried lsusb and the flash drive showed up there but I don’t know how to access it.I am just so new to linux.

Hello @Maxhorse :wink:

Normally just unplug the stick and plug it in. Pretty straight forward.

Anyway… is it listed in:

lsblk --fs

How did you format it? Which file system? Is it encrypted? Is it a new disk? Does it work on a live cd?

I unplugging it and plugging it back in was the first thing I tried and unfortunately now I am here.And also it doesn’t seem to show up with lsblk

I formatted it as ntfs using GParted.

That is strange… please run:

sudo dmesg --follow-new

Then unplug the stick and plug it in and post the output here (copy&paste) :wink:

this is the output

[13791.352074] audit: type=1130 audit(1667762730.357:378): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=unconfined msg='unit=pamac-daemon comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[13796.796138] usb 1-2: USB disconnect, device number 21
[13806.388983] usb 1-1: reset full-speed USB device number 19 using xhci_hcd
[13812.115181] usb 1-2: new high-speed USB device number 22 using xhci_hcd
[13812.261846] usb 1-2: New USB device found, idVendor=13fe, idProduct=4300, bcdDevice= 1.00
[13812.261860] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13812.261867] usb 1-2: Product: USB Flash Drive
[13812.261873] usb 1-2: Manufacturer: Philips
[13812.261878] usb 1-2: SerialNumber: 070A8A7DBBDF5151
[13830.217025]  sda: sda1 sda2 sda3 sda4

When pasting terminal output, add three backticks ` OR 3 tilde ~ above and below the text:


I did it this time for you. Please do it like this in the future.

Thank you :bowing_man:

Well here you see the partitions on that usb stick, which are assigned to sda[1-4]. So here is no problem.

Can you try mounting it?

sudo mount --verbose --mkdir /dev/sda1 /tmp/sda1

And check if it is there?

lsblk --fs

Please post the output, so we can follow you.

I am not sure if those are the partitions of the usb because I am dual booting manjaro with windows that is on sda and linux is on sdb alongside some more windows.Shouldn’t the usb be sdc?But maybe I should try mounting anyway because dmesg finds it.

Likely… but with that information I would assume it that way. :man_shrugging: Anyway… information are needed.

Add also:

sudo parted -l

Is it a USB3 plugged into a USB2 port? I have one that stopped being backwards compatible after being connected to a Windows 10 system.

Kinda.It’s a usb2 plugged into a usb3 port

It doesn’t show up.I am a bit scared to mount it though because this is where windows is.

I think there is nothing more coming from your side and I will not pull anything out of your nose. Good luck, I’m out of here.

I accidently fixed it!I restored it with fedora media writer because it was on my pc and I had nothing to lose.It seemed interesting when I saw it as an option.Originally I wanted to write an iso to it to see if it finds it and what will happen when I write a iso image.So yeah I don’t know how I fixed it but I did.Thanks a lot to everyone who helped!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.