My TTY background is no longer black

I have tried manjaro with different DEs. Eventually I found the manjaro-i3wm suits me well.
The only thing that makes me confused is that my tty background is no longer black. (When I say TTY, it means what I got after pressing Ctrl+Alt+F1-F6)
Now it’s gray-ish, which makes my eyes sore at night.
I’ve seen something like "echo -en “\e]P0000000"”, but that can only be added in my (a .shellrc for fish), and it only takes effect when logged in.
Is there a way I can configure it so that the tty background is always black from boot-up?

Hi @CharlesIX,

Please provide the output of:

cat /etc/bash.bashrc


cat /etc/bash.bashrc.local

If it’s not there, then I don’t know…

Here is my /etc/bash.bashrc

# /etc/bash.bashrc

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

[[ $DISPLAY ]] && shopt -s checkwinsize

PS1='[\u@\h \W]\$ '

case ${TERM} in
    PROMPT_COMMAND+=('printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"')

    PROMPT_COMMAND+=('printf "\033_%s@%s:%s\033\\" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"')

if [[ -r /usr/share/bash-completion/bash_completion ]]; then
  . /usr/share/bash-completion/bash_completion

And I don’t have a /etc/bash.bashrc.local .

BTW, my shell is set to /usr/bin/fish, not bash.
Or I would say, I switched from bash to fish and the problem persists.

Thanks for your time.

When in the TTY, where the background-color is messed up, what is your shell?

You can find this out by running:

echo $SHELL

And what happens when you run:


I suppose you meant TTY.
My shell is /usr/bin/fish.
When I run bash, it literally run bash, and show me my machine info because I put neofetch in my .bashrc .

I mean, are the colours correct?

No. I do not think it is a problem related to shell.
I think something is wrong with tty config.

I really appreciate the manjaro-i3wm developers, but god knows why they changed this tty background color.

Please provide the output of:

cat /etc/vconsole.conf
# This is the fallback vconsole configuration provided by systemd.



OK, nothing there. Was a long shot anyway.

Sorry, I have no further clue, nor could I uncover somefling on the interwebz.


Thank you anyway for your time spared to help me.

1 Like

I got a bit curious about this.

You can use setterm
But it seems a bit wonky.
setterm --background black only changes the background of the prompt for some reason, but after playing around with it I found that setterm --inversescreen on|off did indeed change everything on the screen so I kept trying a bit more…
setterm --clear all --background black actually works, not consistent but it changes it on the tty you are working in.
All of this was done using bash.
You might be able to use that to your advantage?

I think we are getting to the point.
I tried setterm --background black but nothing has changed. setterm --clear all --background black did not work either.
But setterm --inversescreen on|off did change everything on the screen.

Now let me guess:
Would the manjaro-i3wm developers simply changed the definition of colours somehow?
After all the TTY thought it was using “black”, but actually is not.

Can anyone go further on this?

Did you try another color, like green or white?
That would tell you if “black” is not actually black.

Also, make absolutely sure you run bash as shell (~/.bashrc, just typing bash should work, and when logging out you probably have to exit that shell first) when doing these tests to single out what is not working.

Unfortunately, it is of no use to change setterm --background black to setterm --background white.
The latter one did not make the whole screen turn white as setterm --inversescreen on did.

Quite frustrating.

What are you trying to do?

TTY !== virtual terminal

If you are inside i3 window manager - you are not using TTY - but a virtual terminal

In a word, I am trying to make my TTY background black.
I am sure I’m not talking about PTYs and those terminals inside X.

However I found something interesting.
setterm --clear all --background white did make my TTY background white – I tested on both bash and fish.
However, setterm --background white shows no effect in fish, only works in bash.

With that said, I believe it’s something about TTY’s color configuration.

I tried more colours than black and white, only to find “red” is red, and “yellow”“green” all turned to a kind of grey.

I am guessing you have the maia-console package?

pamac search maia-console

It is used with the architect iso profile - it provides - in my eyes - a terrible console experience using the files listed below


Technically you could look at the mentioned maia-console.conf to check what it does

You can remove package - if present - and it will remove the annoyance after reboot

sudo pacman -Rns maia-console

That’s all I got in /etc/systemd/system/getty@.service.d/maia-console.conf.

You are right. The manjaro-i3wm version might has originated from the manjaro-architect project. So there might be some historical issues.

You absolutely saved my day…Though it’s about midnight at my place.
No matter which time zone you are in – Wish you have a good day.