My system does not like pipewire-pulse

I wanted to get rid of pulse because of it not working properly with ALC892 Azalia audio despite scouring the internet for solutions, so I decided to try pipewire and oh boy did it work fine WHEN IT ACTUALLY WORKED

first I purged pulseaudio from my system by doing

sudo pacman -Qe | grep pulse
sudo pacman -Rdd [everything relating pulse]

and then tried to install pipewire a few times over a few days (since it was not working) with

sudo pacman -S manjaro-pipewire
systemctl --user daemon-reload
systemctl --user restart pipewire\*

and during several attempts I also tried both pipewire-media-session and wireplumber, and before each attempt at reinstalling/changing something I even purged /usr/share/pipewire from the system with rm -rf because uninstalling pipewire seemed to not do it but the outcome was always the same: either audio did not play (on spotify the bar went forward without sound, on youtube on chrome the video started but no audio playing with the loading rotating thingy in the middle) OR it started looping like 0.5s of audio, 0.5s of silence in a loop of the same audio like when you have a kernel panic on Windows without the actual system crash, just the audio stopping after a few seconds of this loop.

The only combination of packages that seemed not only to work (on spotify and chrome) but ALSO to survive reboots was pipewire, gst-plugin-pipewire and either pipewire-media-session or wireplumber, and after a few attempts I came to the conclusion that probably my system does not like pipewire-pulse, and I could live with that if only most of the apps I use like discord didn’t need pulse, and also both the volume controls top right and gnome-settings>sound settings don’t work without pipewire-pulse; running pacman -Dk shows (whole output of the command, I did not cut anything):

sudo pacman -Dk
error: missing 'pulseaudio-bluetooth' dependency for 'gnome-bluetooth'
error: missing 'pulseaudio' dependency for 'gnome-settings-daemon'
error: missing 'pulseaudio-alsa' dependency for 'gnome-settings-daemon'

which I suppose are is by pipewire-pulse missing, but if I install pipewire-pulse my audio either doesn’t work or it sounds like a system crash AND THEN it doesn’t work, any ideas? I probably removed something I was not supposed to remove when I removed everything pulse-related before attempting to install pipewire (I remember force removing libpulse-something and another package), and now I don’t know how to diagnose this problem
obs pactl info doesn’t say anything as I don’t have pipewire-pulse right now but when I did it said something along the lines of PulseAudio through pipewire so I thought it was working, also sometimes I managed to make it work with pipewire-pulse and even easyeffects but it didn’t last long as it didn’t survive a reboot

I finally got rid of windows after years, bit the bullet and installed manjaro on my main machine like 5 days ago but I’m willing to learn linux once and for all, so please bear with my ignorance, thank you!

edit1 fixed typo

Still running pulse on a couple of desktops. I have tried to go to Pipewire a couple of times with pretty bad results so was waiting for things to mature a bit… I did find this thread which may or may not help.

Couple of things… 1) this is from about 18 months ago and the “howto” mentioned in the thread I did not find 2) I have not tried changing from Pulse to Pipewire/wireplumber recently. Hopefully someone else can come in and shed some light on what blvckmvgicdotexe is dealing with. Also if there is a how to on installing /switching to pipewire would be good to know where it might be.

Edit-- since my original here I did find the Archwiki on pipewire while, possibly more than you need or want to know is here

Hope this helps. Additionally hope someone more knowledgeable than me will come along and contribute

You should not have done this. You should have just installed manjaro-pipewire and it would have replaced all of your packages for you, so that dependencies aren’t missing.

So far, pipewire works on every game, streaming program, and programs in general that I’ve tested it with.

1 Like


Great suggestion. Used pamac to install manjaro-pipewire. It stripped out all of the pulse audio stuff and installed what was needed. Rebooted and works. Very good call. Wont tell you how I wrestled with this a few months ago when Pipewire was new… many thanks.

Hopefully blvckmvgicdotexe can simply follow the install you have suggested and get his problem resolved…if at worse case his install from either CLI or pamac (what I used) does not work he could remove pipewire, reboot, reinstall pulse, reboot and try installing pipewire again, letting the install program strip out what is needed and install what is needed. I have used Linux for many years and before this, the sound stack was just a disaster. Hopefully pipewire is an end to that.

I only see pipewire-pulse and pipewire running in KDESysguard under the process table. No pulse server running. Only pipewire. I am not going to mark this thread solved since I didnt start it but thank you very much for the suggestion!!

Tip: you can use the at @symbol to tag a forum memeber; i.e., @expat :wink:


Thanks very much for this!!