My Samsung S10 and Computer do not see each other on KDE Connect

Hi
I’m having issues trying to connect my Samsung S10 and computer using KDE Connect.

I’ve installed KDE Connect on my Samsung S10 for the first time and I have it running on my computer as well. I ensured that they were both on the same wifi network. And I tried the troubleshooting steps on the KDE Connect wiki support page for IPTables firewalls. The two devices are still not communicating.

When I run systemctl status iptables.service it says the firewall is inactive.

iptables.service - IPv4 Packet Filtering Framework
Loaded: loaded (/usr/lib/systemd/system/iptables.service; disabled; vendor preset: disabled)
Active: inactive (dead)

I’ve also tried open up my firewalls on my router to see if that helped. I had no success with that either.

After changing those settings and running nmap -v -sT -p1714:1764 with my computer IP address and my router IP address the results come back saying all these ports are closed.

I’m not sure what I’m doing wrong. Can someone tell what I’m missing?

Do you by any chance have the ufw.service up and running? If you do then:

sudo ufw allow 1714:1764/udp
sudo ufw allow 1714:1764/tcp
sudo ufw reload

Hmm. I have a S10, and I have external ssd with KDE. Maybe I can look into it later…

I know it’s not really any help but my note 10 works OK with kde connect. I had to set a rule for firewall but you don’t have a firewall. I needed to install both kde apps on the pc if that helps

I don’t have ufw installed. I ran a whereis and ran the commands and they both came back with that ufw could not be found.

That would be great if you can let me know what you see on your end.

Good to know. I have KDE Connect running on my Manjaro w/ KDE computer and also installed the KDE Connect app on my phone. I had no luck.

There’s kde connect, kde connect indicator, kde connect settings and kde connect sms. I have all 4 installed, not sure if they are all installed by default but I remember when I was on mint I had to install indicator and settings to get it to work

I have two apps installed on my computer tagged with the name KDE Connect. Same version numbers. I’m assuming one is the “Settings” one you are referring to. I do have Indicator and SMS installed as well. I don’t see Settings, Indicator, or SMS on the Google Play app store.

Well I installed the app and paired then connected to it.

Then installed a firewall. then added the rules for it.

1 Like

This is so strange. What version of Manjaro and KDE connect are you running on your computer? I’m on Manjaro 5.19 and my KDE Connect version is 20.08.1-1.

I just brought a 3rd computer of mine back online that is running KDE on Debian and my Manjaro Computer can see the Debian KDE Connect. My phone is also able to see the KDE Debian computer. I’m wondering if this is a versioning issue.

Is your network trusted on the phone app? Go to your kde connect on your phone, hit the hamburger icon top left and go to Settings>Trusted Networks and make sure your network is set as trusted.