My RTX 3070 has a problem with drivers and kernel

If you install Manjaro with kernel 5.13 that denotes you are installing an old ISO.

Make sure you use a current ISO, check Manjaro website to download a proper ISO.

With a current ISO you will install your system on latest LTS kernel, with working Nvidia out of the box.

So I deinstalled 5.13 and installed 5.10. But it still doesn’t work, also installed the free driver you gave me but still didn’t work. I think I will reinstall with the new and updated version.

I feel really sorry and dumb. The version I installed was a bit older and buggy. So I flashed my usb with the newest version and then installed it. Worked, now I am 5.15, should I use it ore change to 5.16 ore to 5.10?
And also how can I apply an ICC profile file that I got for my monitor? Because without it is really bad.
It now works and thank you all for the help. Learned a lot new thing. Also thanks stephane for your help.

Stay on 5.15, do not install other kernels that are not LTS. Keep your system up to date too, do not hold updates for long time so there is no issue to update.

For color profiles, it seems there is colord-kde that should be able to help. Install it and try.

Ok so I got now colord-kde for git repository. It should integrate itself into the system, but it didn’t and I don’t know why.

First, why GIT? There is the package in the Manjaro repositories.

Also after I installed it for testing, and rebooted, it seems it is easily accessible by searching for Color in the Application menu (Color Correction).

sudo pacman -S colord-kde

After reboot, go to System Settings → Hardware → Color Corrections

The Calibrate button warning is expected, see 433068 – Shows "you need Gnome color management installed in order to calibrate devices" it will probably be removed in a later update. Alternatively for this feature, there is Displaycal, also available in the Manjaro repositories, but I doubt you would need that too.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.