My `` startpage crashes all browsers

This is very likely not a problem with Manjaro.

I have a startpage at that I have been using for many years now as a replacement for iGoogle when that was killed by Google.

For the last three or so days, my default web browser, firefox crashed whenever I clicked on any link in my startpage. Scores of tab crash reports have been sent to firefox. The page was rock stable prior to that.

I then tried loading the same page with chromium and with microsoft-edge-dev and on both occasions, the page refused to load. chromium gave an Error code: SIGSEGV.

What would members of this forum suggest?

How might I better troubleshoot this problem to pinpoint the cause? Should I contact or should I try fashioning a new startpage?


Hi @chandra,

I suggest you see if it keeps happening when using a different, clean profile.

If that doesn’t work, try creating the new page as you suggested.

If that still doesn’t work try the same in Chromium, Vivaldi, Brave, Falkon, and/or any others.

That ought to help you to narrow down the cause, or perhaps even find it and fix it.

Hope this helps!

Have you tried without any extensions, especially ad-block extensions?

In case you can’t get it sorted out, this site offers a similar service:

I have tried with a new firefox profile and that was of no avail.

Different browsers also do not help.

My suspicion is this might be a GTK/Plasma mismatch: the theme Breeze-Dark is now missing from the Configure GNOME/GTK Application Style options in KDEsettings.

Software, other than web browsers, seems to work without problems.

FWIW, one last suspicion: the first sign that something is amiss is the loss of the cursor (not visible) as would happen twenty years ago with X11 when graphics problems arose.

I did a firefox refresh (disables extensions, customizations, themes) as advised on the Web and the problem still persists.

I suspect that the release 100 of firefox celebrated by a new window, has undermined the stability that was there previously. In any case, I have sent scores of tab crash reports to Mozilla.

Thanks for the pointer to It might very well be the solution to my problem.

I ran firefox on my protopage startpage using a USB drive live session of Manjaro KDE Plasma 21.2.6. The themes, extensions, and other customizations made to my normal firefox setup have thus been factored out.

firefox crashed even in this setup, very likely due to a segmentation fault, as noted in an earlier post. The screen blacked out and I had to poweroff and boot.( A reboot led to endless jobs being shut down for minutes on end.)

I conclude that there is some problem either with the website (I have contacted them) or with firefox version 100, or both.

Since this behaviour spans different browsers, could there be a bug in a library common to different browsers that has somehow appeared recently? Are there browsers that do not share a library or engine with firefox, chromium, or microsoft-edge-dev?

FYI, I asked someone with firefox on Mac to try my protopage startpage. It could be loaded and browsed without any tab crashes.

This bug erodes confidence: so I would like to see it solved conclusively.


The helpful folks at suggested that I test my memory devices to see if they were causing the problem.

Since a memory test is no more part of the Manjaro boot process, I decided to clean my desktop PC instead. After taking out the memory devices, cleaning them, the connectors, and the sockets, and re-assembling them, I was gratified to discover that the problem with disappeared.

Intermittent issues like the one I experienced could very likely be due to hardware errors, that something as simple as a thorough clean might fix.

EDIT: Since the folks suggested memory testing, I installed memtest86-efi from AUR, installed it to run as a GRUB menu item, and ran the standard test of four passes for almost three hours. Fortuitously, there were no errors. I record this here in case it helps someone else.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.