My mum: Geary does not send emails (but receives them fine)

When she tries to send, Geary fires back at her:

Account Problem
Geary encountered a problem sending email for xxxxx@gmail.com

It then places the email in the unsent box. This problem started out of the blue. It was working fine before. She was not running a software update at the time. The smtp settings look correct.
Geary offers following details:

Account identifier: account_01
Account provider: GEARY_SERVICE_PROVIDER_GMAIL
Service type: GEARY_PROTOCOL_SMTP
Service host: smtp.gmail.com
Error type: GearySmtpError 6
Message: “rcpt to:<com>” failed: 553-5.1.3 The recipient address <com> is not a valid RFC-5321 address. Learn

Back trace:

  • geary_problem_report_construct
  • geary_account_problem_report_construct
  • geary_service_problem_report_construct
  • application_main_window_update_account_status
  • application_controller_expunge_accounts
  • g_closure_invoke
  • g_signal_handlers_destroy
  • g_signal_emit_valist
  • g_signal_emit
  • g_flags_to_string
  • g_object_notify_by_pspec
  • g_closure_invoke
  • g_signal_handlers_destroy
  • g_signal_emit_valist
  • g_signal_emit
  • g_flags_to_string
  • g_object_notify_by_pspec
  • geary_client_service_notify_unrecoverable_error
  • geary_smtp_capabilities_add_ehlo_response
  • g_subprocess_new
  • g_tls_database_lookup_certificates_issued_by_finish
  • geary_smtp_capabilities_add_ehlo_response
  • g_subprocess_new
  • g_tls_database_lookup_certificates_issued_by_finish
  • geary_smtp_capabilities_add_ehlo_response
  • g_subprocess_new
  • g_tls_database_lookup_certificates_issued_by_finish
  • geary_smtp_capabilities_add_ehlo_response
  • g_subprocess_new
  • g_tls_database_lookup_certificates_issued_by_finish
  • geary_smtp_capabilities_add_ehlo_response
  • g_subprocess_new
  • g_tls_database_lookup_certificates_issued_by_finish
  • g_input_stream_close_async
  • g_subprocess_new
  • g_subprocess_new
  • g_main_context_dispatch
  • g_io_channel_new_file
  • g_main_context_iteration
  • g_application_run
  • main
  • __libc_start_main
  • _start

This indicates some problem with the recipient address.
It could be something trivial … like spaces at the end of each one.

Though, this could in fact be simply an odd symptom of an underlying problem …

Such as google has since changed its protocols, while geary (and/or the account settings) have not reflected this change.
(IE - manually recheck configuration according to current gmail standards and/or wait for an update)

Sorry to not give a more definitive answer. Maybe someone else can.

Some example links too:

https://stackoverflow.com/questions/62161786/553-5-1-3-the-recipient-address-is-not-a-valid-rfc-5321-address

Geary Sending Issue - Phones (Librem 5) - Purism community

"Not a valid RFC-5321 address" to a mail I sent messages already - Gmail Community

She has checked that and is confident that there are no unintentional spaces. Both typing the addresses from scratch and pulling them from contacts. Also sending to an email address that she has never sent to before.

Could well be …

Is anyone here who is using Geary with Gmail and does (or does not) have the same problem?

It’s down to a bug or annoyance in Geary. Solution here: Anyone using Gmail with Geary (Gnome email client)? - #13 by TheApologist.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.