My Manjaro only has nvidia 390xx available. How do I get a newer version?

Hi. I have recently migrated from Windows to Manjaro and I want to install nvidia driver. The problems are that the only option I have seems to be 390xx in Add/Remove software and Hardware configuration.
My current gpu is Gtx 1060 6gb

I tried to install the lastest driver by using this command in the terminal
sudo pacman -S nvidia-dkms nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader

But it responded with this error

error: target not found: nvidia-settings
warning: vulkan-icd-loader-1.2.188-1 is up to date – reinstalling
warning: lib32-vulkan-icd-loader-1.2.184-1 is up to date – reinstalling

How do I get the lastest or at least a newer Nvidia driver? I’m quite a noob to Linux.

No idea why your not showing a newer driver, hopefully someone can help with that but manjaro uses mhwd to install drivers rather than pacman

What do the following commands return?

pacman -Qs nvidia

mhwd -l

Also make sure your installation is up to date

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

pacman -Qs nvidia returned

local/egl-wayland 1.1.7-1
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
local/lib32-nvidia-390xx-utils 390.144-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/linux513-nvidia-390xx 390.144-10 (linux513-extramodules)
    NVIDIA drivers for linux.
local/linux514-nvidia-390xx 390.144-1 (linux514-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia 470.63.01-1
    MHWD module-ids for nvidia 470.63.01
local/mhwd-nvidia-390xx 390.144-1
    MHWD module-ids for nvidia 390.144
local/nvidia-390xx-utils 390.144-1
    NVIDIA drivers utilities
local/xf86-video-nouveau 1.0.17-1 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

mhwd -l returned
0000:01:00.0 (0300:10de:1c03) Display controller nVidia Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2020.11.30               false            PCI
video-nvidia-390xx            2020.11.30               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

So you should have the possibility to install the latest drivers (in first command we see you have the MHWD database for latest Nvidia drivers, and second command confirms that there are available for your video card). If the GUI doesn’t show the drivers, then do it from the terminal (with the proper tool):

sudo mhwd -i pci video-nvidia

PS: edit your post, and select your terminal output in your reply, and click the </> button to format it properly instead of it being plain unformated text), or you can manually do it too, like that:

terminal output here

1 Like

Thanks for the tip :smiley: but it came back with

Error: config 'video-nvidia' conflicts with config(s): video-nvidia-390xx

You have already installed the 390 drivers? then remove them first, then install the latest drivers:

sudo mhwd -r pci video-nvidia-390xx

sudo mhwd -i pci video-nvidia


This worked for me! Thanks! But how do I check which version of the driver I currently have?

I have installed this one

| NVIDIA-SMI 470.63.01    Driver Version: 470.63.01    CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| 47%   48C    P8     9W / 120W |    450MiB /  6075MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A       489      G   /usr/lib/Xorg                     186MiB |
|    0   N/A  N/A       986      G   /usr/bin/kwin_x11                  34MiB |
|    0   N/A  N/A      1034      G   /usr/bin/plasmashell               37MiB |
|    0   N/A  N/A      1279      G   /usr/lib/firefox/firefox          166MiB |
|    0   N/A  N/A      1349      G   /usr/lib/firefox/firefox            1MiB |
|    0   N/A  N/A      1499      G   /usr/lib/firefox/firefox            1MiB |
|    0   N/A  N/A      1532      G   /usr/bin/systemsettings5           15MiB |
|    0   N/A  N/A      1594      G   /usr/bin/nvidia-settings            0MiB |

Oh. I’m sorry. This was a dumb question. I’ve just checked it. Silly me lol.

It is literally written in what you copied, on top:

Driver Version: 470.63.01

You can also check which version is the package that MHWD installed by typing the first command I ask you to check

pacman -Qs nvidia

and look for which version the kernel module is at (linux514-nvidia for example, or whatever kernel version you are using)

But basically, video-nvidia should be the latest driver available (Manjaro ships the old legacy 390 driver, and the latest).

Also on a side note, after installing the drivers, and rebooting, do the Manjaro Settings GUI show the drivers available now?

Unfortunately no. It still only shows that only video-nvidia-390xx , video-nvidia are available.

can you clarify your sentence because it is not clear (or take a screenshot and edit your post with it :D), you only have video-nvidia-390xx and video-nvidia, or only video-nvidia-390xx? It is just for my information I saw this issue on a friend computer and just want info.

Yes. I’m sorry. I still only have video-nvidia-390xx and video-nvidia.

Search result on Add/remove software doesn’t show any other version rather than video-nvidia-390xx

replace the cxm with com

Ho OK, so from start you could install the latest drivers. You said “the only option I have seems to be 390xx” so I assume that’s what was your only option, but if you “still only have video-nvidia-390xx and video-nvidia” then you had both right from the start available.

You needed to right click the video-nvidia driver, and then click Install, to install the latest drivers.

video-nvidia = the latest drivers
video-nvidia-390xx = the old legacy 390 drivers

Anyway now it’s installed from terminal it is the same.

Also as said above by sawdoctor, do NOT use Pacman or Pamac (the Add/Remove Software program) or external methods to manage your video drivers, Manjaro has tools to do that properly. It is the same for the kernel, use the Manjaro Settings tool to manage them.

Anyway have fun now.

Noted. Thank you so much <3

1 Like

I think maybe it’s a little confusing to new users. As manjaro only ships the 2 nvidia drivers 390 and the latest the latest is just listed as video-nvidia (unless it’s a laptop then it’s listed differently). As it’s a rolling release driver it’s easier to just name it video-nvidia rather than changing the name everytime the driver updates

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.