My laptop is on Limited Connectivity for 10-15min

My 2012 laptop is on Limited Connectivity for 10-15min…
…sometimes Network Manager will use 100% of a core of my i3 CPU when it begins.
Rebooting helps but it takes a long time on that old HDD.
Or just play the waiting game.
Happens on wired and wifi and around once or twice per day.
It started to happen after the Sept 18 update I think.

Driver is r6168 and I’m using the 6.1.55 kernel.
I also installed the proprietary driver and it is checked alongside the literally free one in the mhwd gui.
But sudo hwinfo --network says r6168 is running, but also lists ath9k maybe this is for wifi?
How do I use the propitiatory driver?

It says active=unknown for both
SysFS ID is class/net/enp19s
or … wlp7s0
The card is Realtek RTL8111/8168/8411

Would love to use 6169 if that helps
and get instructions how.

Yes, ath9k would be your WiFi – a kernel driver for the Atheros chipset.

Some potentially useful information: Network configuration/Wireless.

Does this limited connectivity occur after a period of inactivity; perhaps after being AFK for a while?

No, I am using it when it happens.
Sometimes a running football (AE soccer) game will also continue to stream. But 404 for all other connections.

If it happens only once or twice, it may simply be your ISP dropping the connection temporarily; or resources might be low generally while streaming, which might also produce the same effect; especially on a laptop of that vintage.

However, these are only guesses.

It might be worth trying a slightly older kernel for a few days, to see if that makes a difference.

Yeah, guessing. It is not ISP-wise, it is everywhere I take my laptop and my desktop at home’s connection is not limited at the same time.

Thanks for clarifying.

I suppose you meant r8168 and r8169, rather than r6168 and r6169, respectively:

You could try activating the 5.15 LTS kernel (via Manjaro Settings Manager); which AFAIK has both the r8168 and r8169 kernel drivers.

Please confirm whether you tried this; and let us know if the issue persists.


Cmon, give us useful things.

inxi -Nazy
modinfo ath9k
modinfo r8168

(sic - I’m guessing its r8168 ?)

1 Like

Tycscs. Yeah I got confused with the numbers there.

╭─░▒▓    ~ ▓▒░                                             ░▒▓ ✔  20:23:25  ▓▒░─╮
╰─ inxi -Nazy                                                                       ─╯
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: Foxconn
    driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.0
    chip-ID: 168c:002b class-ID: 0280
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Sony driver: r8168 v: 8.052.01-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 13:00.0 chip-ID: 10ec:8168
    class-ID: 0200

╭─░▒▓    ~ ▓▒░                                      ░▒▓ ✔  6s   20:24:12  ▓▒░─╮
╰─ modinfo ath9k                                                                    ─╯
filename:       /lib/modules/6.1.55-1-MANJARO/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko.zst
license:        Dual BSD/GPL
description:    Support for Atheros 802.11n wireless LAN cards.
author:         Atheros Communications
srcversion:     011CA4DBFF4EF6B31B114E5
alias:          pci:v0000168Cd00000036sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000036sv00001028sd0000020Ebc*sc*i*
<<<<<[...]>>>> SHORTENED
alias:          pci:v0000168Cd00000023sv*sd*bc*sc*i*
alias:          platform:qca956x_wmac
alias:          platform:qca953x_wmac
alias:          platform:qca955x_wmac
alias:          platform:ar934x_wmac
alias:          platform:ar933x_wmac
alias:          platform:ath9k
depends:        ath9k_hw,mac80211,ath9k_common,ath,cfg80211,rfkill
retpoline:      Y
intree:         Y
name:           ath9k
vermagic:       6.1.55-1-MANJARO SMP preempt mod_unload
sig_id:         PKCS#7
signer:         Build time autogenerated kernel key
sig_key:        0C:67:7E:51:D9:21:28:CA:C9:C3:FC:79:BC:69:B5:E8:4C:EB:CF:91
sig_hashalgo:   sha512
signature:      30:65:02:30:6B:3C:4E:55:6C:9F:EA:38:B2:7E:27:7A:DA:6F:D8:18:
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           blink:Enable LED blink on activity (int)
parm:           led_active_high:Invert LED polarity (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int)
parm:           ps_enable:Enable WLAN PowerSave (int)
parm:           use_chanctx:Enable channel context for concurrency (int)
parm:           use_msi:Use MSI instead of INTx if possible (int)

╭─░▒▓    ~ ▓▒░                                             ░▒▓ ✔  20:24:46  ▓▒░─╮
╰─ modinfo r8168                                                                    ─╯
filename:       /lib/modules/6.1.55-1-MANJARO/extramodules/r8168.ko.xz
version:        8.052.01-NAPI
firmware:       rtl_nic/rtl8168fp-4.fw
firmware:       rtl_nic/rtl8168fp-3.fw
firmware:       rtl_nic/rtl8168h-4.fw
firmware:       rtl_nic/rtl8168h-3.fw
firmware:       rtl_nic/rtl8168h-2.fw
firmware:       rtl_nic/rtl8168h-1.fw
firmware:       rtl_nic/rtl8168ep-3.fw
firmware:       rtl_nic/rtl8168ep-2.fw
firmware:       rtl_nic/rtl8168ep-1.fw
firmware:       rtl_nic/rtl8168g-3.fw
firmware:       rtl_nic/rtl8168g-2.fw
firmware:       rtl_nic/rtl8411-2.fw
firmware:       rtl_nic/rtl8411-1.fw
firmware:       rtl_nic/rtl8168f-2.fw
firmware:       rtl_nic/rtl8168f-1.fw
firmware:       rtl_nic/rtl8168e-4.fw
firmware:       rtl_nic/rtl8168e-3.fw
firmware:       rtl_nic/rtl8168e-2.fw
firmware:       rtl_nic/rtl8168e-1.fw
firmware:       rtl_nic/rtl8168d-2.fw
firmware:       rtl_nic/rtl8168d-1.fw
license:        GPL
description:    RealTek RTL-8168 Gigabit Ethernet driver
author:         Realtek and the Linux r8168 crew <>
srcversion:     D5EB0323C7794585FB7A9AC
alias:          pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*
alias:          pci:v000010ECd00002600sv*sd*bc*sc*i*
alias:          pci:v000010ECd00002502sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008161sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
retpoline:      Y
name:           r8168
vermagic:       6.1.55-1-MANJARO SMP preempt mod_unload
parm:           speed_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           duplex_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           autoneg_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           advertising_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           dynamic_aspm:int
parm:           aspm:Enable ASPM. (int)
parm:           s5wol:Enable Shutdown Wake On Lan. (int)
parm:           s5_keep_curr_mac:Enable Shutdown Keep Current MAC Address. (int)
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           timer_count:Timer Interrupt Interval. (int)
parm:           eee_enable:Enable Energy Efficient Ethernet. (int)
parm:           hwoptimize:Enable HW optimization function. (ulong)
parm:           s0_magic_packet:Enable S0 Magic Packet. (int)
parm:           dynamic_aspm_packet_threshold:Dynamic ASPM packet threshold. (int)
parm:           disable_wol_support:Disable PM support. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)

Try replacing r8168 driver with r8169 driver

sudo modprobe -r r8168; sudo modprobe r8169

If the r8169 driver works better than r8168, uninstall r8168 driver and blacklist for r8169

sudo mhwd -r pci network-r8168
1 Like

Thank you. How would I blacklist it?



# use r8169 instead
blacklist r8168

r8168 driver does not need to be blacklisted. just delete or rename file used to blacklist r8169 driver /etc/modprobe.d/r8169_blacklist.conf  /etc/modprobe.d/r8169_blacklist.conf.old

Name of blacklist file can be changed back to original if you want to use r8168 driver again

The only feedback I received from the OP was a :rhinoceros: – whatever that was meant to infer. I’m glad he finally discovered some communication skills. :dodo:

1 Like

Thank you for your efforts, the 3 of you.
Although the Hardware Configuration in the KDE settings menu still (also after 3 reboots) shows 8168 installed (and not the proprietary driver checked en plus anymore), inxi -Nazy shows, hopefully correctly, r8169.

I did that and didn’t have to

[not “”] because that file was auto-deleted upon the uninstall of 6168 (the second command above). So I didn’t change anything there.

Now I will observe over next days if the problems persists and hopefully eventually mark the thread as solved. Cheers! :clock7:

Ok, the problem persists. I always notice at the end of a Duolingo lessen (flatpak). Then the stream I was was watching would continue to run, the its data transferred was shown in the System Tray. Where the connection shows as Limited after a minute or two. Any other connections seems to be refused. If you reload any Firefox tab, including the one with the stream: fail.
I used to have that problem the whole time I was watching Acestream (older python, app was never updgraded), on my main PC.

Do you have any application that might automatically check for updates or some other resource (such as blocklists, for example); in the background whenever the system becomes idle?

There is potential here for causing limited connectivity if this (hypothetical) application temporarily maximizes (hogs) bandwidth to achieve its goal.

Yes… I’m using Portmaster. Just looked and it auto updates and downloads filter-list updates (it won’t say how often).
System Tray would however show that traffic? But worth to try shutting it down next time it happens, to rule it out/ see if the problem will go away by that.

1 Like

It definitely has to do with Portmaster. It even geoblocks me sometimes. Must have to do DNS settings. Let me fondle the settings and a way of running it without the gui and then mark it as solved finally…

Being that it’s beta grade software, no doubt it still has a few wrinkles to iron out. You might also try disabling the blocklists for a time, in case legitimate traffic is sporadically blocked by over-zealous inclusions.

1 Like

I haven’t found a solution, however a workaround that is opening the Portmaster gui and restarting it.
Issue occurs both when running the or gui, the gui/minimized, or just the system.d service.