My laptop freeze or has black screen when I open the lid after suspend


Since when I bought this laptop (Huawei Matebook D14, it has a AMD Ryzen 5 3500U CPU with a Radeon Vega 8 GPU) and installed Linux on it (it’s dualbooting with Windows), I have this problem that happens randomly, not always, but it’s very annoying.

Basically when I open the lid of my laptop, it freezes. I can’t do anything. The only thing I can do is to shutdown manually with the button.

Actually in this last period, it doesn’t freeze, but the screen is black. I only can see the cursor and it changes when I move it in different areas of the screen (in fact even if I can’t see anything, if I try to put the password and press enter, I notice that in someway I am able to login because my cursor change again and it’s like I am moving the cursor in the windows that I had when I closed the lid, but again, I can’t see anything). Since I don’t see anything, I can only manually shutdown with the button (I tried going to a tty but I can’t see anything too). It’s a very annoying bug because I lose every activity of the session.

I have this problem in all the distros that I have tried: Manjaro, Kubuntu, etc… and now also in Archlinux with KDE.

The problem happens sometimes. Not always. I noticed that sometimes (with the lid closed) the fan are working and when I open the lid I have the bug described. Maybe it’s related to the fan(?)
The fan powering on when lid is closed are also on Windows, but Windows doesn’t freeze.

I am able to login via SSH when all this happens.

This is journalctl log where I was able to move the cursor and also enter the password and login (even if I didn’t see anything):

journalctl when I closed lid at 19:37:51. I opened the lid at 19:55:06 and it was black as usual and I couldn’t see anything, I can just move the cursor and also I can put the password and login (I can because if I do it I notice that the cursor changes like if I am moving around the windows that I had opened before I closed the lid, but again, I can’t see anything). As you can see, the laptop does not suspend. Is it maybe interrupted by NetworkManager(?). I am able to login via SSH.

this time I didn’t close the lid, I just left the laptop without power cable, so I think it went in suspension after some minutes (10:11:54 precisely in the logs). After some time I went again to the laptop(10:27:53) and realized that it was suspended, but I saw that it freezed again… Classic black screen.
I could access via SSH, so I decided to poweroff via SSH(10:29:49), instead of manually and forcibly powering off via button. But I waited and nothing was happening, laptop wasn’t shut dowm, it’s like it was freezed in shutdown process.
here’s the related journalctl:

If I close the lid and I go to sleep, and the morning I run “dmesg -T”, I notice that my pc has activities even if it should be suspended for all the night. Is it normal or it isn’t?

1 Like

Try using Kernel 5.4 and see if it fixes your Problems. 5.9+ does not really work for me too.

I have this issue with all the kernels that I tried actually

I suspect that this might be the amdgpu issue plaguing AMD laptop users (like me) for several weeks now. At some time some amdgpu-dev apparently broke suspend for many users and it hasn’t been properly fixed since. What happens is that amdgpu locks up the entire system. It briefly worked again for me with 5.11.6, but fails to work on newer kernels.
As a consequence I’m still on 5.11.6.

Anyway, last time I checked it also worked on 5.10.32 so I assume that later 5.10 kernels should be fine too (checked - works for me). I haven’t checked 5.11.18 or 5.12.1, though (edit: did so now, 5.12.1 is not ok).

so it’s still non fixed

Not on all Kernel versions, at least - assuming it’s the same issue.

Some general things.
Yes, sometimes it is normal that a PC wakes up. The OS can ask EFI for these wakes, depending on time passed or battery status. Also, if you got a mouse attached, they might move just a tiny bit and wake the pc. That is not uncommon.
But since you still see your mouse-courser, it might work to get to console (strg+alt+F2) and back to desktop (alt+F1). While at command line, you could also try to restart X.
sudo systemctl restart sddm (if you use kde kde)

I have this problem in all kernel versions that I tried until now though.

thanks for infos. If I try to get to a tty as you suggested I still can’t see anything, so it’s difficultt to know what I am doing, but I’ll try what you suggest.

last thing that I tried is to edit these lines in /etc/default/grub, because people suggested it:

GRUB_CMDLINE_LINUX="vga=current ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2 iommu=pt idle=nomwait acpi_backlight=vendor acpi_enforce_resources=lax scsi_mod.use_blk_mq=1"

but with no luck, the problem still occurs…

It’s some time that I don’t have the issue anymore, since I switched to lts kernel.
The strange fact is that when I had Manjaro installed, I tried using an lts kernel, but the issue still happened.
But under archlinux when I switched to lts kernel and when I REMOVED the boot parametres, I didn’t get anymore the freeze.

1 Like

Great to see that it works again for you!
I think that the latest 5.10 LTS kernels have a fix for the issue - they work fine for me since 5.10.30 or such. So far the fix doesn’t seem to have made it into 5.11 or 5.12, though (but I’m still waiting for the next stable update on Manjaro)…

1 Like

A post was split to a new topic: Suspension/Hibernation causing black screen

I’m marking this thread as solved based on the above.

Closing to prevent necro-bumping