My keyboard layout and locale resets every 10 minutes

Dear @codesardine, did you figure out the solution for this bug?

I’ve got the same problem. I tried to set Latvian -> Default in “Keyboard settings” reset to British -> Default (same as my OS locale) every 10 minutes, even without reboot. This is very confusing. If you need any data or info from me, I would gladly help.

PS. Are these settings a part of Manjaro or KDE? Why would someone have “Keyboard settings” (see above) and “Input devices → Keyboard” (see below) so similar and located in different places? Extremely confusing.

I am in no way sure of this, so if I’m wrong feel free to correct me someone.

I suspect the first one is the default, thus system-wide configuration, while the second one is custom per-user configuration/overrides.

I’m getting all the more feeling I’m right. The first one in under the Manjaro section/header, which I think is for the whole system. The second one is under the Personalisation section IIRC, which is the user’s custom, personal settings.

Thank you, @Mirdarthos, for elaboration. Nevertheless, this Manjaro settings is confusing AND the chosen settings resets back (is somehow reverted) after 10-20 minutes on both Gnome and KDE.

You’re welcome!

I have absolutely no idea what could be the problem then, since I’ve never seen/heard of/had anything of the sort. So I’ll be keeping a close eye on this thread for future reference.