My kde desktop is laggy and slow

Hi there hope all doing great, i had manjaro kde 3 years ago and it was ok, after one year for some reasons(for experience lighter desktop) i migrate to manjaro xfce and every thing was ok. but some days ago i decide to upgrade my system and put ssd and improve graphic becuse i love kde desktop. btw my previous graphic card was amd HD 5450 1GB, and curently i have NVIDIA Geforce Gt 710 2GB +SSD. my problem is my current kde is laggy and much much slower than my xfce , i cant remmember 3 years ago it was same or not, another thing is idk the problem is about NVIDIA graphic
driver or something else . i just install manjaro by selecting install with opensource drivers. and also i click on both button which i have attached to this topic. (i dont know i have this bad experince with this graphic card in xfce or not bcus i didnt test it in on my xfce),thanks for your help .

1 Like

*sorry i cant attached image idk why. but those buttons was “auto install properietary drivers”
and “auto install open source drivers”

It’s your GPU. It lacks power to drive a GUI such as the KDE plasma desktop. A GT 710 is too old and not a real upgrade from your previous graphics card.


so you clicked on all available buttons … most likely you ended up with both installed and not a happy mix.

Please open up terminal and run:
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-modesetting
sudo mhwd -a pci nonfree 0300

but i think i had much better experince with my previous graphic card which much powerless than this one. and also 3 years ago my pc was core i3, and now its core i5

i faced this error for your second command
Error: config ‘video-modesetting’ is not installed!

Ok, is not an issue, just wanted to make sure you do not have something else installed.

so there is no way :(.?
but why in comparison these cards Nvidia won in all sites
i cant put link here its illegal

I think you should have now the 390xx driver installed. See from terminal:
mhwd -li
and there are a few tricks that can make KDE Plasma work smoother.
Let us know, once you rebooted is works better than with fee drivers.

here is the result

                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2020.11.30               false            PCI

Warning: No installed USB configs!

i hope your trick was not disable desktop effects :smiley: bcus i cant live without that option lol

See here

You should put the contents of inxi -Gx so that we can see what driver is actually installed. Again that graphics card is not going to be enough for plasma.

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_TELEPH[quote="Framani, post:13, topic:67777, full:true"]

You should put the contents of inxi -Gx so that we can see what driver is actually installed. Again that graphics card is not going to be enough for plasma.

ONE = "en_US.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_TIME = "fa_IR.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
Graphics:  Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 460.80 bus-ID: 01:00.0 
           Device-2: Jieli USB PHY 2.0 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 2-1.6:5 
           Display: x11 server: X. Org 1.20.11 driver: loaded: nvidia resolution: 1366x768~60Hz 
           OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 460.80 direct render: Yes

thanks buddy, its been faster :D. so any other idea?
edited:i also change resolution from “1366*768” to “1280 *720” with first one i have a little vibration on my topbar, but with second one its solid

have you tried changing to opengl or xrender in the compositor?

i just install manjaro by selecting install with opensource drivers

if you have a nvidia graphics card shouldn’t you select propietary drivers? I think open source are for AMD only.


i tryed xrender but i faced more lag, and also all desktop effect have been removed.
and for your second sentence ,idk acutally

Friend the folks here are trying to tell you that if you have an Nvidia card it should have installed with proprietary drivers

And don’t free them as you chose during installation

So I think you should look for the proprietary drivers for your card at mhwd

Sorry my bad english (google translate)

T+ = See you later

go to manjaro settings and clic on devices or hardware configuration. you will see your nvidia card. Install the driver for that card from there. Try that and keep us posted with the result.