My internet connection is no longer working

Got burned by this update… my internet connection is no longer working(PPoE type) so i’m posting this using a older live usb version of manjaro(with this one was able to connect fine with no issues just by creating&using a new PPoE connection)

Something got changed i’m guessing its either the new network manager version or smth else relating to a message i saw scrolling by during update in the terminal window telling me the ping was changed to or smth along these lines, wasn’t paying much attention at the time and later coudn’t find any mention of this in the pacman update log…

Either way i’m quite annoyed by this kind of crap slipping by into a stable release… ah well its time to do some more digging i guess

If any of you guys got a clue on what was changed and how to revert it pls post it, other then that ill try and do a downgrade to the network mnager and see if that solves anything(don’t expect it would more likely its just a settings change that did this)

PS:i may have found the culprit while trying to downgrade the network manager i saw this message(same one that came during update i belive): Changing NetworkManager Connectivity-Ping to now all i need to do i find out where to change this setting and what was its original value before this mess occurred… Seems this is not caused by this but smth else as after changing the value back to its original in usr/lib/NetworkManager/conf.d/20-connectivity.conf it still not working.

Well downgrading the network manager to either one of 2 previous versions i had didn’t do anything so its definitely a recent change introduced by this update that killed my internet connection…
Now what was changed and how do i revert those changes is what I want to know… before i lose my temper and scrap the OS altogether.

1 Like

well, hard to tell what it might be but it would be useful to submit the inxi-output below, that would show if the driver is enabled. are you using lan or wifi ? from what i read your networkmanager is total broken. there had been so much fatal issues in recent months that it’s hard to suggest what it might be but maybe this two links can give you some help to dig into the problem. because of right that same behaviour i started to use a clone-backup and i always backup before updating this general “big” updates as today. the chance to break a rolling-release is something you must always accept if you’re using rolling release.
hope you’ll get it running back again
fingers crossed

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


Changing DNS with systemd-resolved not working with PPPoE seems to be related to the above ,can’t even begin to understand what i’m supposed to do about it with no internet access from within my bootable hdd partition.
Anyways ill post the result of the command you gave me soon after yet another reboot to my internet capable usb stick OS…

This is all that was network related that I found after issuing that comand

Use of uninitialized value $args in concatenation (.) or string at /usr/bin/inxi line 2584.
Use of uninitialized value in concatenation (.) or string at /usr/bin/inxi line 2584.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (6) Could not resolve host:
Use of uninitialized value $args in concatenation (.) or string at /usr/bin/inxi line 2584.
Use of uninitialized value in concatenation (.) or string at /usr/bin/inxi line 2584.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (6) Could not resolve host:
Use of uninitialized value $args in concatenation (.) or string at /usr/bin/inxi line 2584.
Use of uninitialized value in concatenation (.) or string at /usr/bin/inxi line 2584.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (6) Could not resolve host:

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8168 v: 8.049.02-NAPI modules: r8169 pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac:
WAN IP: No WAN IP found. Connected to web? SSL issues?

This is the result of systemctl status NetworkManager

NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; >
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
Active: active (running) since Mon 2022-03-14 17:51:35 EET; 7min ago
Docs: man:NetworkManager(8)
Main PID: 507 (NetworkManager)
Tasks: 3 (limit: 19110)
Memory: 21.2M
CPU: 828ms
CGroup: /system.slice/NetworkManager.service
└─507 /usr/bin/NetworkManager --no-daemon

mar 14 17:57:22 ANK pppd[1332]: nm-ppp-plugin: status 10 / phase ‘terminate’
mar 14 17:57:22 ANK pppd[1332]: nm-ppp-plugin: status 8 / phase ‘network’
mar 14 17:57:22 ANK pppd[1332]: nm-ppp-plugin: status 5 / phase ‘establish’
mar 14 17:57:22 ANK NetworkManager[507]: [1647273442.6034] device (ppp>
mar 14 17:57:22 ANK pppd[1332]: nm-ppp-plugin: status 11 / phase ‘disconnect’
mar 14 17:57:22 ANK pppd[1332]: Connection terminated.
mar 14 17:57:22 ANK NetworkManager[1332]: Connection terminated.
mar 14 17:57:22 ANK pppd[1332]: nm-ppp-plugin: status 1 / phase ‘dead’
mar 14 17:57:22 ANK pppd[1332]: nm-ppp-plugin: cleaning up
mar 14 17:57:22 ANK pppd[1332]: Exit

Anyways got no clue how to proceed any further…

just a first try, maybe it’s just such simple, but i don’t believe in but anyways it doesn’t harm:

sudo systemctl restart NetworkManager.service

same here; after this update and rebooting a few times,i can’t connect to the internet.
I’m using DSL/PPPoE with a username and password provided by the ISP.
i tried restarting the Network Manager service but to no avail.
i’m quit annoyed as i have things to do.
i’d appreciate some urgent help.

  Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=a445c87d-e6a9-47fd-9601-614f3b3e7781 rw quiet apparmor=1
    security=apparmor resume=UUID=29e42246-1548-46dd-91f5-17d1f76c7bfd
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: TUF Gaming FX705GD_FX705GD v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX705GD v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX705GD.306 date: 05/25/2020
  ID-1: BAT0 charge: 56.8 Wh (100.0%) condition: 56.8/64.1 Wh (88.5%)
    volts: 16.3 min: 15.6 model: Simplo SDI ICR18650 type: Li-ion
    serial: <filter> status: Full cycles: 41
  Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 3856 high: 4100 min/max: 800/4100 scaling:
    driver: intel_pstate governor: performance cores: 1: 3863 2: 4052 3: 3913
    4: 4010 5: 3327 6: 4052 7: 3724 8: 3728 9: 3917 10: 4100 11: 3728 12: 3866
    bogomips: 52815
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1c8d
    class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-11:4 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 model: AU Optronics built: 2018 res: 1920x1080 hz: 60
    dpi: 128 gamma: 1.2 size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 476.94 GiB used: 64.99 GiB (13.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston
    model: RBUSNS8154P3512GJ size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: E8FK11.C temp: 45.9 C scheme: GPT
  ID-1: / raw-size: 467.84 GiB size: 459.5 GiB (98.22%)
    used: 64.99 GiB (14.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 57.0 C pch: 47.0 C mobo: 27.8 C
  Fan Speeds (RPM): cpu: 0
  Processes: 297 Uptime: 17m wakeups: 1 Memory: 15.48 GiB
  used: 2.93 GiB (18.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1371 lib: 398 flatpak: 0
  Shell: Zsh v: 5.8.1 running-in: konsole inxi: 3.3.13

Edit: i’m currently using a mobile Hotspot.

Nope that was the first thing i have tried myself… smth changed with this update in some network manager related file… problem is I lack the familiarity to even know what exact files are those and if I can simply replace them with a functional prior version of themselves from my bootable usb stick…

Its amazing how smth like this slipped into the stable build… either way i’m out of ideas and short of taking some more blind shots based on the arch wiki tomorrow ill just call it quits and scrap the distro altogether in favor of smth that doesn’t require me to flip trough douzens of wiki pages just to get a simple working PPoE connection.

Welcome to the club linub seems like you got the same exact issue i got and suspect more folks will be joining use soon enough(probably all that are using a dsl/ppoe)

seems that you’re 2 with same issue now. That seems to be an issue with PPoE-connections. Hopefully some cracks will join the thread and are able to give more knowledge than me.
is there a possibility to downgrade ?

@grraf already tried as mentioned in his first post.

What says ip addr ?

If you are refering to the network manager i already tried that but it doesn’t help hence my assumption that some settings files got modified somewhere and isnt an issue of the networkmanger itself.
But as i stated before i’m no dev and haven’t got a clue what those files are and what was changed to them.

is safe to share?and does it matter now that i’m using a Hotspot+VPN?

is this related?

there’s a command they suggest that might fix it,but not sure i should run it.

It happened to me as well, except I couldn’t access specific domains for whatever reason, i.e. google, and judging from the comments you left, I decided to downgrade the version of Network Manager.

If you don’t have it, install the downgrade package:
sudo pacman -S downgrade

After that, downgrade the networkmanager package:
sudo downgrade networkmanager

Select any version prior to 1.36, I chose 1.34 and after that’s done, just restart the service:
sudo systemctl restart NetworkManager

Hope this helps at least someone, I’m not sure how to go about this if you’ve lost connection to the outside world. :frowning:


ip addr only shows your network connection and not your ip adress.

unfortunately i cleared old packages sometime ago.
can i download NetworkManager 1.4 from a manjaro repository?

Well a downgrade of both networkmanager&libnm to version 1.34 then doing sudo systemctl restart NetworkManager does the trick…

The reason i failed on my first downgrade attempt was due to not also downgrading libnm alongside networkmanager

Anyways thank you folks for yr help i guess its problem solved for now…

If I had to guess, you could try:

pacman -U

Which should install 1.34 for you, but like @grraf wrote, you might also need to downgrade the libnm package as well.

1 Like

is there a list like that for Manjaro?
shouldn’t a package be ported/ built or compiled for manjaro first?(i have no idea what i’m saying)

Well Arch packages worked for me whenever I needed to get something working on Manjaro, and since it’s Arch-based, things tend to “just work” with Arch packages.

i’ve manually downloaded both
libnm-1.34.0-1-x86_64.pkg.tar.zst and networkmanager-1.34.0-1-x86_64.pkg.tar.zst
can i just put them both in /var/cache/pacman/pkg/ and do a downgrade from there with :
downgrade networkmanager
downgrade libnm ?

That’s exactly what i did :point_up:

Thanks @crni , you’ve been of great help.