My encrypted boot drive will no longer boot. I just updated

Some of this background info may or may not have any relevance to the issue I am experiencing, but it all happened at the same time. I have been running Manjaro on my Thinkpad E15G2 Ryzen 4700U laptop for a few years, and keep it updated. I am installed Manjaro with full disk encryption and have to enter my decryption key on boot. After several seconds the system will boot into Manjaro XFCE.

This morning I saw the list of updates and updated my system. After booting up I got a notification that there is a new kernel available. I was running 5.16 and usually update to new kernels when available. I have had a couple times where there was an issue and I had to roll back to a previous version but that has been the extent of my issues, so I went ahead and installed 5.17.

Upon rebooting I found that my two DisplayLink USB monitors no longer work. This was undesired behavior of course so I decided to roll back to Kernel 5.16. At some point in the past I had edited my grub file to hide the boot menu, so I edited it again to show the menu. After rebooting I still did not see the menu, so I did some more research and this pointed to running update-grub after making changes, so I did. This seemed to work fine and after rebooting and entering my decryption key I get this:

:: running early hook [udev]
Starting version 250.4-2-manjaro
:: running hook [udev]
:: Triggering events...
:: running hook [keymap]
:: Loading keymap...done
:: running hook [encrypt]
Waiting for 10 seconds for device /dev/disk/by-uuid/<longStringOfCharacters> ...
Waiting for 10 seconds for device /dev/disk/by-uuid/<longStringOfCharacters> ...
ERROR: device 'UUID=<longStringOfCharacters>' not found. Skipping fsck.
:: mounting 'UUID=<longStringOfCharacters>' on real root
mount: /new_root: can't find UUID=<longStringOfCharacters>.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

This was not expected, so I rebooted and let the new kernel run again, but got the same result. Every boot attempt since has had the same results. I have done a crazy amount of reading up on this trying to resolve the issue, and tried too many things to list here, but none of my changes made any difference in the boot message.

Ultimately, if I boot into a Manjaro Live-Cd I can see and unlock the LUKs partition just fine, and have confirmed that the UUID is exactly the as listed in the error above, but nothing I have tried to do with the system from the Live-CD has made any difference except uncommenting the ‘GRUB_DISABLE_LINUX_UUID=true’ line, which resulted in a different message about not finding some other device that I don’t believe exists.

My laptop is now unusable, and if at all possible I would much prefer to avoid a fresh install and restoring all my programs and data from backups.

Does anyone have any idea what might have happened here and how I can resolve it? The error on the surface seem pretty clear. The UUID that the boot process is looking for cannot be found. However since confirming that this UUID exists and is the correct device via Live-CD I’m not sure what could be causing this issue.

One thing I made progress on but hesitate to go too far with is that I can chroot into the mount point and then su to my user, but I cannot run Timeshift to roll back without sudo, and it won’t let me use sudo. Some research has shown that I need to remount with some extra parameters but I’m concerned about hosing the filesystem. I am not familiar with chroot although I certainly came along way today.


check this out, looks like your issue, just follow the steps in the ‘solution’

I had found that post this morning, but since it was based on a new install that never worked I didn’t pursue those steps since my installation has been working for years. I never came back to it but I went through those steps now and it worked! Thank you for bringing it back to my attention!

I still wish I knew what caused the issue in the first place though.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.