My computer froze during an update

Hello, a few days ago i updated my system using

pacman -Syu

During the update my system froze and i had to restart. And after doing so this message shows up

file `/boot/vmlinuz-5.10-x86_64’ not found

So i got a live use and and chrooted into my system with this method

After doing so i tried runnig

pacman -Syu

But returned no output my guess is that it broke during the failed update.
Any suggestions on how to fix pacman or reinstall my kernel again

With what? Post output of pacman update.

thats the thing there is no output pacman is broken returns nothing no matter the command

Did you skip primary school? Or can you use some punctuation in your sentences?

Let me fetch fix-everything commands…

if your going to help then do it, dont have time for you

ok then bye

1 Like

You have an issue
and you are describing it very poorly.
And you are giving no context
nor the commands you ran and the result you got from doing so.

You have a problem.
You want help.
Don’t reject it because someone criticises you in a way you don’t like.
Your run on, multi line sentence without punctuation is hard to read.

The remedy now is probably to chroot
and re-run the interrupted update that way.

Thanks for the advice i was not trying to describe it poorly.
I am a not an advanced Linux user nor a native english speaker i tried describing the best i could with my knowledge of the problem
He didn’t want to help but to be disrespectful and i told he i didn’t have time to argue either if he could help i would appreciate if not just ignore the thread
But your way of responding is the right way i will try to restructure the question.

… and that is your hurt ego speaking
he may be blunt, but wants to help, is here to help
and is very much capable to do so

not everyone wants to explain the very basics again and again - even though it only takes one line and very few keystrokes

And how am i supposed to respond to this then?

… either not at all
or with an apology :man_shrugging:

Lol he wants help, but you are teaching him English

Can you help?

Exactly my point. If you don’t like how i wrote my question then sure positive criticism I’m all for it but to just make fun of me
You have to know that not everyone speaks English natively
And I’m supposed to apologise.

rerun update from chroot and post output from it

You seem to be reading it well enough.
Seem to be understanding the issue.


especially when keeping in mind that you are the one in want for assistance

anyway - I told you what will likely remedy your issue


pacman -Syu

From chroot returns no output

If you can’t respond in a polite and positive manner, do not respond at all.

Hey, none of us are perfect and I’ve also experienced burnout. Take a break, man. You’re a valuable member here and we’ll see you on the other side. :wink:


You are 100% right. But I can’t promise anything. :stuck_out_tongue:


open new terminal window and install this into the live usb:
sudo pacman -S arch-install-scripts
then reinstall pacman and its dependecies:

sudo pacstrap -i /mnt pacman glibc bash libarchive curl gpgme gettext gawk coreutils gnupg pacman-mirrors libpamac pkgfile 

hopefully that will be enough, and then from the chrooted window, rerun the update again, and see if it worked