My Bluedevil is all over the place


Since a few updates, I had issues with KDE’s graphical front end for Bluetooth. I tries to fix it quickly but didn’t manage to find any “clean” solution, only tricks, and it got progressively worse. By now, the bluetooth manager has become entirely useless. I can’t use it to add new devices (he fails to connect), but it does say my keyboard is connected (while the bluetooth connection mode of my keyboard is off and it only works because plugged through usb). The initial problem I had with my keyboard was that after waking my system from sleep, it wouldn’t connect back via bluetooth.

My Sixaxis gamepad is the worst of the devices right now. It doesn’t appear in the tray icon at all, and when I try to add it through the wizard, it fails every single time. I can have a stable connection through blutoothctl but only with the usb cable plugged in. When I had it working like that, I had inputs in only some games, while other games didn’t recognized it. I had to force the Steam Input Off in the steam game settings, and even then I had wrong inputs.

This seems to be a bit too many issues at the same time for me to handle. I read the arch page for Gamepad, Bluetooth and Keyboard many times, but nothing helps. I’ve tried so many things since I first started to have those issues that I do not trust the grounds I’m troubleshooting on. I’d like to get a “fresh install” on all the bluetooth related component, but I’m not sure how to proceed. I reinstalled through pacman the bluedevil, bluez, bluez-plugins, and bluez-utils but it didn’t help.

In Bluetoothctl, everything seems fine except this part:

[CHG] Device 00:1B:FB:63:A5:A5 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1B:FB:63:A5:A5 ServicesResolved: yes
[CHG] Device 00:1B:FB:63:A5:A5 WakeAllowed: yes
Failed to connect: org.bluez.Error.Failed
[CHG] Device 00:1B:FB:63:A5:A5 Trusted: yes
[CHG] Device 00:1B:FB:63:A5:A5 ServicesResolved: no

After that error, the device connects until unplugged.

When looking around, I see people advising to use blueman. I do not have any other front end installed at the moment (I checked), but I remember trying that at least once in the past.

If anyone has an idea of how to proceed, or what to look for, I would appreciate the help. It’s been at least three or four times that I try to fix it and I’m stuck. Thanks.

[edit] My system’s infos.

  Kernel: 5.14.0-0-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=a51fc9a1-f9ae-4271-aa15-66755b5fbe71 rw quiet 
  resume=UUID=05548c21-2b0a-4447-8e7f-89f0d27c57af udev.log_priority=3 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0 
  serial: <filter> UEFI: American Megatrends LLC. v: H.C0 date: 01/25/2021 
  Message: No system battery data found. Is one present? 
  RAM: total: 15.55 GiB used: 5.93 GiB (38.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D cache: L2: 3 MiB 
  bogomips: 81627 
  Speed: 2804 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 
  1: 2804 2: 2928 3: 2451 4: 3309 5: 2828 6: 2970 7: 2596 8: 2716 9: 2502 
  10: 2507 11: 3462 12: 2314 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rapl rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca 
  sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall 
  tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 2d:00.0 
  chip-ID: 1002:67ff class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 305 size: 160x90mm (6.3x3.5") 
  diag: 184mm (7.2") 
  OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.42.0 
  5.14.0-0-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 2d:00.1 
  chip-ID: 1002:aae0 class-ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 2f:00.3 chip-ID: 1022:1457 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.14.0-0-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.19 running: no 
  Sound Server-4: PulseAudio v: 15.0 running: no 
  Sound Server-5: PipeWire v: 0.3.34 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel port: d000 
  bus-ID: 27:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic scope: global broadcast: <filter> 
  IP v6: <filter> type: dynamic mngtmpaddr noprefixroute scope: global 
  IP v6: <filter> scope: link 
  IF-ID-1: mlvd-fr5 state: unknown speed: N/A duplex: N/A mac: N/A 
  IP v4: <filter> scope: global 
  IP v6: <filter> scope: global 
  WAN IP: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-6:2 chip-ID: 0a12:0001 class-ID: e001 
  Report: bt-adapter ID: hci0 rfk-id: 4 state: up address: <filter> 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 476.94 GiB used: 240.84 GiB (50.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 PRO 512GB 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: 4B6QCXP7 temp: 39.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 205.94 GiB size: 201.71 GiB (97.94%) 
  used: 27.91 GiB (13.8%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: N/A uuid: a51fc9a1-f9ae-4271-aa15-66755b5fbe71 
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A 
  uuid: B8B9-CF91 
  ID-3: /home raw-size: 58.59 GiB size: 57.42 GiB (98.00%) 
  used: 41.7 GiB (72.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 6426c4dd-b4cb-43f5-bf34-3edf4d6ac05e 
  ID-4: /home/<filter>/Videos raw-size: 195.31 GiB size: 191.25 GiB (97.92%) 
  used: 171.15 GiB (89.5%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 
  label: N/A uuid: 14dcd9e8-cf7a-4146-a9eb-b45ac5c67f0e 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.6 GiB used: 79.9 MiB (0.5%) 
  priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4 label: N/A 
  uuid: 05548c21-2b0a-4447-8e7f-89f0d27c57af 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-6:2 info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 0a12:0001 class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-1:5 info: Holtek OBINS type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s 
  power: 400mA chip-ID: 04d9:a293 class-ID: 0300 serial: <filter> 
  Device-2: 3-5:2 info: Micro Star MYSTIC LIGHT type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 1462:7c37 class-ID: 0300 serial: <filter> 
  Hub-4: 3-6:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0608 class-ID: 0900 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 5-3:2 info: Logitech G502 Proteus Spectrum Optical Mouse 
  type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 300mA chip-ID: 046d:c332 class-ID: 0300 
  serial: <filter> 
  Hub-7: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 55.2 C mobo: N/A gpu: amdgpu temp: 37.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1173 
  Processes: 329 Uptime: 1d 1h 15m wakeups: 20 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1437 
  lib: 440 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.06

In a new user account, my keyboard connected fine and the notification tray displays the correct status. It continues to work as I came back to my regular user account. It seems like it worked after my system woke up from sleep, so it fixed it for me.

The gamepad is still a problem. I have to use bluetoothctl to trust it and connect it, that’s the only way for it to work. In game (Hades), I have wrong inputs. The gamepad still doesn’t show up in the bluetooth notification tray nor the system settings, but it does show up in the Input Devices > Game Controller section.

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Does this also happen in a newly created user? (E.G. robz772-2)


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.

1 Like

So AFAIU, everything is working now except for the wrong inputs in Hades and the original issue was/is sleep-driven?


Yes I think that’s the only issue left.

I tried to look the groups my users are in:
My user:

[marylou@marylou-pc ~]$ groups marylou
wheel input lp sys network power marylou

And the account I created for testing:

[marylou@marylou-pc ~]$ groups test
audio lp optical video sys network scanner power test

So you have an issue in your user profile and finding out which exact setting you changed is going to take weeks if not months, therefore, we’re going to do the following:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups twitty
    groups twitty2

    (Where obviously, twitty is your old user and twitty2 is your new one.)
    E.G. if twitty is a member of operator and twitty2 isn’t, execute:

    usermod --append --groups operator twitty2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=timestamps /home/twitty/Documents/* /home/twitty2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/twitty/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/
  • After everything has been copied over, disable the old user so you cannot accidentally log on to it any more:

     usermod --lock twitty
  • If you would have theming or other customisations going on, don’t do everything in one day but do this at the rate of 1 application / theme / … per day and if the same issue crops up again, roll back your last change and thus you’ve now pinpointed the exact setting that made your old user misbehave. :thinking:

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:

As to the remaining sleep issue, please read this:

Especially the section Linux has multiple kernels and then try an LTS kernel and see if the problem goes away automagically :grin:


1 Like

Thanks to your (detailed) answer! This fix requires to be thorough, I’m gonna have to plan it ahead and read your comment a couple of times before committing…

It will be a bit complicated on my machine because I lack storage space.
I messed up the partitioning when I installed Manjaro (was the first time I was using Linux) and I created a root partition taking a third of my total capacity, thinking my games and apps would be on that. But obviously that’s not how it works.

I believe I can directly re-partition my system without any data losses? Is that correct?

Also I think you are right and I’m gonna switch to the LTS kernel. Most of my issues came from updating it, in retrospect. I learned a lot fixing stuff though :slight_smile:

Thanks again a ton for your help, you guys are great! Thank you!

That’s a whole different topic all by itself. Just create new post if none exists already, ping me @Fabby and I’ll answer that too.


1 Like